Results 1 to 7 of 7

Thread: Filename with spaces (character) didn't play in VOD via cupertino iOS?

  1. #1
    Join Date
    Jul 2010
    Posts
    9

    Question Filename with spaces (character) didn't play in VOD via cupertino iOS?

    is there a way that my filename of the video for example "Big Movie Part 25.mp4" can be play? We have Thousands of videos which has "space" character on the video filename and we cannot rename all due to it will affect also html and php files which needed to edit them.

    Is there a way in the wowza setting to enable spaces character so the video can play ok via VOD cupertino iOS ?

    or HTML5 video tag is the one that didnt treat this filename with spaces that cause not to play the video?

    Also I try to use %20 to replace the space character but it didnt work also

    thanks

  2. #2

    Default

    the only thing I can think of is to use the AliasProvider interface to see if you can manipulate it as needed.

    http://www.wowzamedia.com/forums/con...der2-interface

    Shamrock

  3. #3
    Join Date
    Jul 2010
    Posts
    9

    Default

    hi thanks for the reply, question how can I apply the link you provided? TIA

  4. #4
    Join Date
    Dec 2007
    Posts
    28,369

    Default

    I tested iOS playback with file name containing space without problem. Did you quote the video src attribute?

    Code:
    <html>
    <head>
      <title>Playlist</title>
    </head>
    <body>
    <table><tr><td>
    <video src="http://192.168.1.5:1935/vod/sample space.mp4/playlist.m3u8"</video>
    </td></tr></table>
    </body>
    </html>
    Richard

  5. #5
    Join Date
    Jul 2010
    Posts
    9

    Default

    hi, I'm using the quote on the src, still not working, do you think there is a setting which can cause error on the filename when it has a space character? thanks

  6. #6

    Default

    Quote Originally Posted by zearth View Post
    hi thanks for the reply, question how can I apply the link you provided? TIA
    you would need to use the Wowza IDE and build a module, however further reading suggests it should work.

    Can you post the src link, change your server IP, so we can see it ?

    Shamrock

  7. #7
    Join Date
    Dec 2007
    Posts
    28,369

    Default

    About space in name problem, not sure. It works for me. All browsers URLEncode, and Wowza does URLDecode.

    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •