Results 1 to 9 of 9

Thread: Wowza's Classpath

  1. #1

    Default Wowza's Classpath

    I know that Wowza attempts to load JARs from $WOWZA_HOME/lib, but does it try loading from anywhere else? I have a ton of JARs required for my application, but I don't want to dump them all in the lib directory, as I want to keep it pretty slim if possible. Is there anywhere else which Wowza looks for regarding JARs, such as conf/{app-name}/lib or applications/{app-name}/lib?

    If not, how would I modify Wowza's start script to load another directory as a part of the classpath?

  2. #2


    They can only be loaded from this folder.


  3. #3


    If I wanted to add JARs to the classpath, what file should I modify in the bin directory?

  4. #4


    Any .jar file added to the lib folder will automatically be picked up in the class path. We have our own class loader that handle this.


  5. #5


    Does it also pick up files in subdirectories under lib?

  6. #6


    No, it does not.


  7. #7



    I write a module for geo blocking. I have to load an external file for this.
    Where is the best place to load this?
    If I put it into conf or lib it will not get loaded via


    I don't want to put it in the jar itself, this would make it more uncomforable to update the dataSource.

    Thanks for helping me,


  8. #8
    Join Date
    Dec 2007


    It should work in the conf folder. The content folder is another option that should work


  9. #9


    I have had success with modifying the bin/ Adding onto the -cp operator.. like so:

    $_EXECJAVA $JAVA_OPTS $JMXOPTIONS -Dcom.wowza.wms.runmode="standalone" -Dcom.wowza.wms.native.base="osx" -Dcom.wowza.wms.AppHome="$WMSAPP_HOME" -Dcom.wowza.wms.ConfigURL="$WMSCONFIG_URL" -Dcom.wowza.wms.ConfigHome="$WMSCONFIG_HOME" -cp "$WMSAPP_HOME/bin/wms-bootstrap.jar:$WMSAPP_HOME/custom_libs" com.wowza.wms.bootstrap.Bootstrap start

    So I added the folder "custom_libs" to the classpath.

    So when you run the ./ it will have it on the classpath... this is good for testing it worked. For a permanent classpath modification when Wowza starts up with the init script.. you need to modify the file similarly to the file. You'll see a similar line in the file as existed in the

    Hope that helps.

    Last edited by jakehilton; 07-21-2012 at 09:46 AM. Reason: Added more info.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts