Results 1 to 2 of 2

Thread: HTTPStreamerSessionCupertino.setStreamName() only works for logging???

  1. #1

    Default HTTPStreamerSessionCupertino.setStreamName() only works for logging???

    Hi all,

    I'm trying hard to rewrite a stream name, since I need to encode the actual stream name for security. I've gotten as far as successfully decrypting the requested stream name, but now I can't tell wowza what the real stream name is....

    HTTPStreamerSessionCupertino.setStreamName(unencryptedStreamName);

    Only works for logging, and not for the real stream name used by wowza...

    Here is the code snippet (ignore the decryption stuff...)

    Code:
    	public void onHTTPCupertinoStreamingSessionCreate(HTTPStreamerSessionCupertino httpCupertinoStreamingSession)
    	{
    
    		// This is the encrypted video file
    		String streamName = httpCupertinoStreamingSession.getStreamName();
    		getLogger().info("streamName: "+streamName);
    
    	    // ...DECRYPTION CODE
    
    		getLogger().info("unencryptedStreamName: " + unencryptedStreamName);
    
    		httpCupertinoStreamingSession.setStreamName(unencryptedStreamName);
    		getLogger().info("streamName: "+httpCupertinoStreamingSession.getStreamName());
    
    
    	}
    which results in:

    Code:
    2011-11-27      23:09:35        CET     comment server  INFO    200     -       streamName: 7RdA0yCuwW3i51zwakWB9BpIccu7Glrs7FL+UyYnkHEYmfgf05LagCaBzDmXKt5fny20MMQIzvHD1N/CVRpgbg==    -       -       -       0.313
    2011-11-27      23:09:35        CET     comment server  INFO    200     -       unencryptedStreamName: testdir/RoboCupSoccer_Robot_Football_at_2009_German_Open.mp4     -       -       -       0.314   -       -
    2011-11-27      23:09:35        CET     comment server  INFO    200     -       streamName: testdir/RoboCupSoccer_Robot_Football_at_2009_German_Open.mp4        -       -       -       0.315   -       -       -
    
    2011-11-27      23:09:35        CET     comment server  WARN    404     7RdA0yCuwW3i51zwakWB9BpIccu7Glrs7FL+UyYnkHEYmfgf05LagCaBzDmXKt5fny20MMQIzvHD1N/CVRpgbg==        MediaReaderH264.open[1]: java.io.FileNotFoundException: /usr/local/WowzaMediaServer/content/ivod/7RdA0yCuwW3i51zwakWB9BpIccu7Glrs7FL+UyYnkHEYmfgf05LagCaBzDmXKt5fny20MMQIzvHD1N/CVRpgbg== (No such file or directory)  -       -       -       0.32    -       -       -       -       -       -
    You can see that the setStreamName is working in the logs, because the streamName is showing the unencrypted version. However, Wowza is still 404ing with the original steramName....

    How can I set the streamName in the session????

    Many many thanks for any pointers.

  2. #2

    Default

    Amazing what a good night's sleep can do!

    IMediaStreamNameAliasProvider2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •