Results 1 to 7 of 7

Thread: HTTPStreamerCupertinoIndexPlaylist.indexFile[streaml]: MediaList is empty

  1. #1

    Default HTTPStreamerCupertinoIndexPlaylist.indexFile[stream]: MediaList is empty

    We are on Wowza Media Server 3 Monthly Edition 3.0.4 build1127, and get this error in the log file when any attempt is made to stream ngrp urls from iOS. The odd thing is this exact server and configuration worked fine for weeks. We were getting no video, just audio from iOS and restarted Wowza, and this problem has shown up, and now we cannot stream at all to iOS. This has happened before on other servers, and we ended up switching to a smil file for multi-bit rate iOS streaming. Still, it seems odd that nothing on the server changed but this error has shown up suddenly.

    Here is the transrate.xml file we're using, I can provide other configuration if necessary.

    Code:
    <Root>
    	<Transcode>
    		<Encodes>
    			<!-- Example Encode block for source, not required unless Member of StreamNameGroup. --> 
    			<Encode>
    				<Enable>false</Enable>
    				<Name>source</Name>
    				<StreamName>mp4:${SourceStreamName}_source</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceVideoBitrate}</Bitrate>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
    			<Encode>
    				<Enable>true</Enable>
    				<Name>high</Name>
    				<StreamName>mp4:${SourceStreamName}_640x480_640</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    						<FitMode>fit-height</FitMode>
    						<Width>640</Width>
    						<Height>480</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>main</Profile>
    					<Bitrate>640000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 360p, high bandwith, main profile for desktop -->
    			<Encode>
    				<Enable>true</Enable>
    				<Name>medium</Name>
    				<StreamName>mp4:${SourceStreamName}_416x234_300</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    						<FitMode>fit-height</FitMode>
    						<Width>416</Width>
    						<Height>234</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>main</Profile>
    					<Bitrate>300000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 240p, medium bandwidth, baseline profile -->
    			<Encode>
    				<Enable>false</Enable>
    				<Name>240p</Name>
    				<StreamName>mp4:${SourceStreamName}_240p</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
    						<FitMode>fit-height</FitMode>
    						<Width>360</Width>
    						<Height>240</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>baseline</Profile>
    					<Bitrate>350000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
    			<Encode>
    				<Enable>true</Enable>
    				<Name>low</Name>
    				<StreamName>mp4:${SourceStreamName}_320x180_150</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
    						<FitMode>fit-height</FitMode>
    						<Width>320</Width>
    						<Height>180</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>baseline</Profile>
    					<Bitrate>150000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    		</Encodes>
    		<Decode>
    			<Video>
    				<Deinterlace>false</Deinterlace>
    				<Overlays>
    					<Overlay>
    						<Enable>false</Enable>
    						<Index>0</Index>
    						<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    						<Opacity>100</Opacity>
    						<Location>
    							<X>5</X>
    							<Y>5</Y>
    							<Width>${ImageWidth}</Width>
    							<Height>${ImageHeight}</Height>
    							<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    							<Align>left,top</Align>
    						</Location>
    					</Overlay>
    				</Overlays>
    				<Parameters>
    				</Parameters>
    			</Video>
    			<Properties>
    			</Properties>
    		</Decode>
    		<StreamNameGroups>
    			<!-- Note: Play stream using stream name ngrp:[stream-name] -->
    			<StreamNameGroup>
    				<Name>${SourceStreamName}_all</Name>
    				<Members>
    					<Member>
    						<EncodeName>low</EncodeName>
    					</Member>
    					<Member>
    						<EncodeName>medium</EncodeName>
    					</Member>
    					<Member>
    						<EncodeName>high</EncodeName>
    					</Member>
    				</Members>
    			</StreamNameGroup>
    			<StreamNameGroup>
    				<Name>${SourceStreamName}_mobile</Name>
    				<Members>
    					<Member>
    						<EncodeName>240p</EncodeName>
    					</Member>
    					<!--<Member>
    						<EncodeName>160p</EncodeName>
    					</Member>-->
    				</Members>
    			</StreamNameGroup>
    		</StreamNameGroups>
    		<Properties>
    		</Properties>
    	</Transcode>
    </Root>
    Last edited by grantk; 03-19-2012 at 07:26 AM.

  2. #2
    Join Date
    Mar 2010
    Posts
    2

    Default

    Hello,
    i also had this issue, the cause was that i didn't checked the audio box within fmle encoder.
    Damien

    Quote Originally Posted by grantk View Post
    We are on Wowza Media Server 3 Monthly Edition 3.0.4 build1127, and get this error in the log file when any attempt is made to stream ngrp urls from iOS. The odd thing is this exact server and configuration worked fine for weeks. We were getting no video, just audio from iOS and restarted Wowza, and this problem has shown up, and now we cannot stream at all to iOS. This has happened before on other servers, and we ended up switching to a smil file for multi-bit rate iOS streaming. Still, it seems odd that nothing on the server changed but this error has shown up suddenly.

    Here is the transrate.xml file we're using, I can provide other configuration if necessary.

    Code:
    <Root>
    	<Transcode>
    		<Encodes>
    			<!-- Example Encode block for source, not required unless Member of StreamNameGroup. --> 
    			<Encode>
    				<Enable>false</Enable>
    				<Name>source</Name>
    				<StreamName>mp4:${SourceStreamName}_source</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceVideoBitrate}</Bitrate>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
    			<Encode>
    				<Enable>true</Enable>
    				<Name>high</Name>
    				<StreamName>mp4:${SourceStreamName}_640x480_640</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    						<FitMode>fit-height</FitMode>
    						<Width>640</Width>
    						<Height>480</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>main</Profile>
    					<Bitrate>640000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 360p, high bandwith, main profile for desktop -->
    			<Encode>
    				<Enable>true</Enable>
    				<Name>medium</Name>
    				<StreamName>mp4:${SourceStreamName}_416x234_300</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    						<FitMode>fit-height</FitMode>
    						<Width>416</Width>
    						<Height>234</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>main</Profile>
    					<Bitrate>300000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 240p, medium bandwidth, baseline profile -->
    			<Encode>
    				<Enable>false</Enable>
    				<Name>240p</Name>
    				<StreamName>mp4:${SourceStreamName}_240p</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
    						<FitMode>fit-height</FitMode>
    						<Width>360</Width>
    						<Height>240</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>baseline</Profile>
    					<Bitrate>350000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    			<!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
    			<Encode>
    				<Enable>true</Enable>
    				<Name>low</Name>
    				<StreamName>mp4:${SourceStreamName}_320x180_150</StreamName>
    				<Video>
    					<!-- H.264, PassThru -->
    					<Codec>H.264</Codec>
    					<!-- default, CUDA, QuickSync -->
    					<Transcoder>default</Transcoder>
    					<FrameSize>
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
    						<FitMode>fit-height</FitMode>
    						<Width>320</Width>
    						<Height>180</Height>
    						<!-- <Crop>0,0,0,0</Crop> -->
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    					</FrameSize>
    					<Profile>baseline</Profile>
    					<Bitrate>150000</Bitrate>
    					<KeyFrameInterval>
    						<FollowSource>true</FollowSource>
    						<Interval>60</Interval>
    					</KeyFrameInterval>
    					<Overlays>
    						<Overlay>
    							<Enable>false</Enable>
    							<Index>0</Index>
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    							<Opacity>100</Opacity>
    							<Location>
    								<X>5</X>
    								<Y>5</Y>
    								<Width>${ImageWidth}</Width>
    								<Height>${ImageHeight}</Height>
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    								<Align>left,top</Align>
    							</Location>
    						</Overlay>
    					</Overlays>
    					<Parameters>
    					</Parameters>
    				</Video>
    				<Audio>
    					<!-- AAC, PassThru -->
    					<Codec>PassThru</Codec>
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    				</Audio>
    				<Properties>
    				</Properties>
    			</Encode>
    		</Encodes>
    		<Decode>
    			<Video>
    				<Deinterlace>false</Deinterlace>
    				<Overlays>
    					<Overlay>
    						<Enable>false</Enable>
    						<Index>0</Index>
    						<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    						<Opacity>100</Opacity>
    						<Location>
    							<X>5</X>
    							<Y>5</Y>
    							<Width>${ImageWidth}</Width>
    							<Height>${ImageHeight}</Height>
    							<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    							<Align>left,top</Align>
    						</Location>
    					</Overlay>
    				</Overlays>
    				<Parameters>
    				</Parameters>
    			</Video>
    			<Properties>
    			</Properties>
    		</Decode>
    		<StreamNameGroups>
    			<!-- Note: Play stream using stream name ngrp:[stream-name] -->
    			<StreamNameGroup>
    				<Name>${SourceStreamName}_all</Name>
    				<Members>
    					<Member>
    						<EncodeName>low</EncodeName>
    					</Member>
    					<Member>
    						<EncodeName>medium</EncodeName>
    					</Member>
    					<Member>
    						<EncodeName>high</EncodeName>
    					</Member>
    				</Members>
    			</StreamNameGroup>
    			<StreamNameGroup>
    				<Name>${SourceStreamName}_mobile</Name>
    				<Members>
    					<Member>
    						<EncodeName>240p</EncodeName>
    					</Member>
    					<!--<Member>
    						<EncodeName>160p</EncodeName>
    					</Member>-->
    				</Members>
    			</StreamNameGroup>
    		</StreamNameGroups>
    		<Properties>
    		</Properties>
    	</Transcode>
    </Root>

  3. #3

    Default

    Thanks for that, but the encoding has not changed at all either, and we had audio fine on flash clients.

  4. #4
    Join Date
    Dec 2007
    Posts
    28,412

    Default

    Are you able to play the individual streams that are in the group: the low, medium and high streams?

    Richard

  5. #5

    Default

    Hi Richard, we've since moved to a different configuration, but the streams should play individually, since a .smil file works. Thanks.

  6. #6
    Join Date
    Dec 2007
    Posts
    28,412

    Default

    Great. Sounds like you are saying it is working now. Thanks for the update.

    Richard

  7. #7
    Join Date
    Feb 2013
    Posts
    2

    Default Having exactly the same issue

    Hello!

    I'm having the same issue. I can play individually each stream the Transcoder delivers but when it comes to ngrp:Stream2_all says: Medialist empty. This is my transrate.xml.

    thank you in advance
    Code:
    <!-- Example template for transrate, producing four new streams at different bitrates. Resultant streams can be played back individually or as a group. source, 360p and 160p encode blocks are enabled through the Enable property, other examples are not enabled. Add additional encode blocks to your template as needed. -->
    
    <Root>
    
    	<Transcode>
    
    		<Encodes>
    
    			<!-- Example Encode block for source, not required unless Member of StreamNameGroup. --> 
    
    			<Encode>
    
    				<Enable>true</Enable>
    
    				<Name>source</Name>
    
    				<StreamName>mp4:${SourceStreamName}_source</StreamName>
    
    				<Video>
    
    					<!-- H.264, H.263, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<Bitrate>${SourceVideoBitrate}</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Video>
    
    				<Audio>
    
    					<!-- AAC, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Audio>
    
    				<Properties>
    
    				</Properties>
    
    			</Encode>
    
    			<!-- Setup for 720p, high bandwith, main profile for desktop or set-top box -->
    
    			<Encode>
    
    				<Enable>false</Enable>
    
    				<Name>720p</Name>
    
    				<StreamName>mp4:${SourceStreamName}_720p</StreamName>
    
    				<Video>
    
    					<!-- H.264, H.263, PassThru, Disable -->
    
    					<Codec>H.264</Codec>
    
    					<!-- default, CUDA, QuickSync -->
    
    					<Transcoder>default</Transcoder>
    
    					<GPUID>-1</GPUID>
    
    					<FrameSize>
    
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    
    						<FitMode>fit-height</FitMode>
    
    						<Width>1280</Width>
    
    						<Height>720</Height>
    
    						<!-- <Crop>0,0,0,0</Crop> -->
    
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    
    					</FrameSize>
    
    					<Profile>main</Profile>
    
    					<Bitrate>1300000</Bitrate>
    
    					<KeyFrameInterval>
    
    						<FollowSource>true</FollowSource>
    
    						<Interval>60</Interval>
    
    					</KeyFrameInterval>
    
    					<Overlays>
    
    						<Overlay>
    
    							<Enable>false</Enable>
    
    							<Index>0</Index>
    
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    
    							<CheckForUpdates>false</CheckForUpdates>
    
    							<Opacity>100</Opacity>
    
    							<Location>
    
    								<X>5</X>
    
    								<Y>5</Y>
    
    								<Width>${ImageWidth}</Width>
    
    								<Height>${ImageHeight}</Height>
    
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    
    								<Align>left,top</Align>
    
    							</Location>
    
    						</Overlay>
    
    					</Overlays>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Video>
    
    				<Audio>
    
    					<!-- AAC, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Audio>
    
    				<Properties>
    
    				</Properties>
    
    			</Encode>
    
    			<!-- Setup for 360p, high bandwith, main profile for desktop -->
    
    			<Encode>
    
    				<Enable>true</Enable>
    
    				<Name>360p</Name>
    
    				<StreamName>mp4:${SourceStreamName}_360p</StreamName>
    
    				<Video>
    
    					<!-- H.264, H.263, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<!-- default, CUDA, QuickSync -->
    
    					<Transcoder>default</Transcoder>
    
    					<GPUID>-1</GPUID>
    
    					<FrameSize>
    
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source -->
    
    						<FitMode>fit-height</FitMode>
    
    						<Width>640</Width>
    
    						<Height>360</Height>
    
    						<!-- <Crop>0,0,0,0</Crop> -->
    
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    
    					</FrameSize>
    
    					<Profile>main</Profile>
    
    					<Bitrate>350000</Bitrate>
    
    					<KeyFrameInterval>
    
    						<FollowSource>true</FollowSource>
    
    						<Interval>60</Interval>
    
    					</KeyFrameInterval>
    
    					<Overlays>
    
    						<Overlay>
    
    							<Enable>false</Enable>
    
    							<Index>0</Index>
    
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    
    							<CheckForUpdates>false</CheckForUpdates>
    
    							<Opacity>100</Opacity>
    
    							<Location>
    
    								<X>5</X>
    
    								<Y>5</Y>
    
    								<Width>${ImageWidth}</Width>
    
    								<Height>${ImageHeight}</Height>
    
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    
    								<Align>left,top</Align>
    
    							</Location>
    
    						</Overlay>
    
    					</Overlays>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Video>
    
    				<Audio>
    
    					<!-- AAC, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Audio>
    
    				<Properties>
    
    				</Properties>
    
    			</Encode>
    
    			<!-- Setup for 240p, medium bandwidth, baseline profile -->
    
    			<Encode>
    
    				<Enable>true</Enable>
    
    				<Name>240p</Name>
    
    				<StreamName>mp4:${SourceStreamName}_240p</StreamName>
    
    				<Video>
    
    					<!-- H.264, H.263, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<!-- default, CUDA, QuickSync -->
    
    					<Transcoder>default</Transcoder>
    
    					<GPUID>-1</GPUID>
    
    					<FrameSize>
    
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
    
    						<FitMode>fit-height</FitMode>
    
    						<Width>360</Width>
    
    						<Height>240</Height>
    
    						<!-- <Crop>0,0,0,0</Crop> -->
    
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    
    					</FrameSize>
    
    					<Profile>baseline</Profile>
    
    					<Bitrate>350000</Bitrate>
    
    					<KeyFrameInterval>
    
    						<FollowSource>true</FollowSource>
    
    						<Interval>60</Interval>
    
    					</KeyFrameInterval>
    
    					<Overlays>
    
    						<Overlay>
    
    							<Enable>false</Enable>
    
    							<Index>0</Index>
    
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    
    							<CheckForUpdates>false</CheckForUpdates>
    
    							<Opacity>100</Opacity>
    
    							<Location>
    
    								<X>5</X>
    
    								<Y>5</Y>
    
    								<Width>${ImageWidth}</Width>
    
    								<Height>${ImageHeight}</Height>
    
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    
    								<Align>left,top</Align>
    
    							</Location>
    
    						</Overlay>
    
    					</Overlays>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Video>
    
    				<Audio>
    
    					<!-- AAC, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Audio>
    
    				<Properties>
    
    				</Properties>
    
    			</Encode>
    
    			<!-- Setup for 160p, low bandwith, baseline profile for 3G mobile devices such as iOS, Android, Blackberry -->
    
    			<Encode>
    
    				<Enable>true</Enable>
    
    				<Name>160p</Name>
    
    				<StreamName>mp4:${SourceStreamName}_160p</StreamName>
    
    				<Video>
    
    					<!-- H.264, H.263, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<!-- default, CUDA, QuickSync -->
    
    					<Transcoder>default</Transcoder>
    
    					<GPUID>-1</GPUID>
    
    					<FrameSize>
    
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
    
    						<FitMode>fit-height</FitMode>
    
    						<Width>284</Width>
    
    						<Height>160</Height>
    
    						<!-- <Crop>0,0,0,0</Crop> -->
    
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    
    					</FrameSize>
    
    					<Profile>baseline</Profile>
    
    					<Bitrate>200000</Bitrate>
    
    					<KeyFrameInterval>
    
    						<FollowSource>true</FollowSource>
    
    						<Interval>60</Interval>
    
    					</KeyFrameInterval>
    
    					<Overlays>
    
    						<Overlay>
    
    							<Enable>false</Enable>
    
    							<Index>0</Index>
    
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    
    							<CheckForUpdates>false</CheckForUpdates>
    
    							<Opacity>100</Opacity>
    
    							<Location>
    
    								<X>5</X>
    
    								<Y>5</Y>
    
    								<Width>${ImageWidth}</Width>
    
    								<Height>${ImageHeight}</Height>
    
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    
    								<Align>left,top</Align>
    
    							</Location>
    
    						</Overlay>
    
    					</Overlays>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Video>
    
    				<Audio>
    
    					<!-- AAC, PassThru, Disable -->
    
    					<Codec>PassThru</Codec>
    
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Audio>
    
    				<Properties>
    
    				</Properties>
    
    			</Encode>
    
    			<!-- Setup for H.263, low bandwith, streaming to older mobile devices -->
    
    			<Encode>
    
    				<Enable>false</Enable>
    
    				<Name>h263</Name>
    
    				<StreamName>mp4:${SourceStreamName}_h263</StreamName>
    
    				<Video>
    
    					<!-- H.264, H.263, PassThru, Disable -->
    
    					<Codec>H.263</Codec>
    
    					<!-- default, CUDA, QuickSync -->
    
    					<Transcoder>default</Transcoder>
    
    					<GPUID>-1</GPUID>
    
    					<FrameSize>
    
    						<!-- letterbox, fit-width, fit-height, crop, stretch, match-source  -->
    
    						<FitMode>letterbox</FitMode>
    
    						<Width>176</Width>
    
    						<Height>144</Height>
    
    						<!-- <Crop>0,0,0,0</Crop> -->
    
    						<!-- <SourceRectangle>0,0,320,240</SourceRectangle> -->
    
    					</FrameSize>
    
    					<Profile>baseline</Profile>
    
    					<Bitrate>150000</Bitrate>
    
    					<KeyFrameInterval>
    
    						<FollowSource>false</FollowSource>
    
    						<Interval>60</Interval>
    
    					</KeyFrameInterval>
    
    					<Overlays>
    
    						<Overlay>
    
    							<Enable>false</Enable>
    
    							<Index>0</Index>
    
    							<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    
    							<CheckForUpdates>false</CheckForUpdates>
    
    							<Opacity>100</Opacity>
    
    							<Location>
    
    								<X>5</X>
    
    								<Y>5</Y>
    
    								<Width>${ImageWidth}</Width>
    
    								<Height>${ImageHeight}</Height>
    
    								<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    
    								<Align>left,top</Align>
    
    							</Location>
    
    						</Overlay>
    
    					</Overlays>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Video>
    
    				<Audio>
    
    					<!-- AAC, PassThru, Disable -->
    
    					<Codec>AAC</Codec>
    
    					<Bitrate>64000</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Audio>
    
    				<Properties>
    
    				</Properties>
    
    			</Encode>
    			
    			<Encode>
    
    				<Enable>true</Enable>
    
    				<Name>radio</Name>
    
    				<StreamName>mp4:${SourceStreamName}_radio</StreamName>
    
    				<Audio>
    
    					<!-- AAC, PassThru, Disable -->
    
    					<Codec>AAC</Codec>
    
    					<Bitrate>${SourceAudioBitrate}</Bitrate>
    
    					<Parameters>
    
    					</Parameters>
    
    				</Audio>
    
    				<Properties>
    
    				</Properties>
    
    			</Encode>
    
    		</Encodes>
    
    		<Decode>
    
    			<Video>
    
    				<Deinterlace>false</Deinterlace>
    
    				<Overlays>
    
    					<Overlay>
    
    						<Enable>false</Enable>
    
    						<Index>0</Index>
    
    						<ImagePath>${com.wowza.wms.context.VHostConfigHome}/content/wowzalogo.png</ImagePath>
    
    						<CheckForUpdates>false</CheckForUpdates>
    
    						<Opacity>100</Opacity>
    
    						<Location>
    
    							<X>5</X>
    
    							<Y>5</Y>
    
    							<Width>${ImageWidth}</Width>
    
    							<Height>${ImageHeight}</Height>
    
    							<!-- horiz: left, right, hcenter - vert: top, bottom, vcenter -->
    
    							<Align>left,top</Align>
    
    						</Location>
    
    					</Overlay>
    
    				</Overlays>
    
    				<Parameters>
    
    				</Parameters>
    
    			</Video>
    
    			<Properties>
    
    			</Properties>
    
    		</Decode>
    
    		<StreamNameGroups>
    
    			<!-- Note: Play stream using stream name ngrp:[stream-name] -->
    
    			<StreamNameGroup>
    
    				<Name>${SourceStreamName}_all</Name>
    
    				<Members>
    
    					<Member>
    
    						<EncodeName>source</EncodeName>
    
    					</Member>
    
    					<Member>
    
    						<EncodeName>720p</EncodeName>
    
    					</Member>
    
    					<Member>
    
    						<EncodeName>360p</EncodeName>
    
    					</Member>
    
    					<Member>
    
    						<EncodeName>240p</EncodeName>
    
    					</Member>
    
    					<Member>
    
    						<EncodeName>160p</EncodeName>
    
    					</Member>
    
    					<Member>
    
    						<EncodeName>radio</EncodeName>
    
    					</Member>
    
    				</Members>
    
    			</StreamNameGroup>
    
    			<StreamNameGroup>
    
    				<Name>${SourceStreamName}_mobile</Name>
    
    				<Members>
    
    					<Member>
    
    						<EncodeName>240p</EncodeName>
    
    					</Member>
    
    					<Member>
    
    						<EncodeName>160p</EncodeName>
    
    					</Member>
    
    				</Members>
    
    			</StreamNameGroup>
    
    		</StreamNameGroups>
    
    		<Properties>
    
    		</Properties>
    
    	</Transcode>
    
    </Root>

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •