Results 1 to 7 of 7

Thread: Wowza - Port forwarding behind NAT

  1. #1
    Join Date
    Oct 2011
    Posts
    16

    Default Wowza - Port forwarding behind NAT

    Hi,

    I have a problem with RTSP streaming over UDP because of port forwarding.
    I think I have found a reason using WireShark, but I need someone to confirm and/or suggest a solution.

    1. Internet client sends UDP packet from IP A : 555
    2. Packet is received and forwarded from inner router IP B : [random port 777] to local Wowza IP
    3. Wowza starts sending video to B : 555
    4. Packets are not forwarded to client outer ip A, because forwarding table expects 777 but not 555

    How do I handle this situation?

    Thanks.

  2. #2
    Join Date
    Oct 2011
    Posts
    16

    Default

    Did you try streaming to RTSP mobile using this network configuration?

    Because in my case incoming packets are successfully forwarded to Wowza.
    But Wowza responds to internet client port, not to local router port.

    Do I have to make some changes in config files?
    Or is it possible to set remote UDP port by plugin?
    Last edited by Xeon[13]; 05-08-2012 at 05:57 AM.

  3. #3

    Default

    Hi,

    Probably you just need the RTSP setup tutorial.
    Last edited by randall; 05-08-2012 at 07:45 AM.

  4. #4

    Default

    Also, this is all on your local network, correct? You don't have more than one router doing NAT do you?

  5. #5
    Join Date
    Oct 2011
    Posts
    16

    Default

    Thank you for the tutorial. I configured these settings before and it didn't help.

    Originally the problem was in different network, and I believe there is one router.

    So I simulated the situation in my local network with port forwarding tool and three machines: client, router and server.



    Please note that everything works fine if Wowza is connected directly to the internet.

  6. #6

    Default

    What kind of router is it? Custom iptables?

    Internal NAT table should be based off of source port. UDP packets will be addressed to the destination IP/port; the router records the source IP/port in the address translation table and replaces them with router IP and random port, which is then sent to Internet client. UDP is not stateful, so the scenario you're describing shouldn't matter. It seems you are not allowing new connections through the router.

    Should be:
    C>S: 1935
    C>S: (tell server to use client UDP ports)
    S>C: (tell client to use server UDP ports starting at 6790 which is the default for Wowza)
    C<->S: 1935
    S>C: (from server UDP ports to client UDP ports)
    C>S: (from client UDP ports to server UDP ports)

  7. #7
    Join Date
    Oct 2011
    Posts
    16

    Default

    Thanks! That might help.
    I am currently waiting for the reply from IT department.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •