Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: How to start streams at server startup (StartupStreams.xml)

  1. #1

    Default How to start streams at server startup (StartupStreams.xml)


    This forum post has moved to the following article:

    http://www.wowzamedia.com/forums/content.php?75

    Enjoy,
    The Wowza Team
    Last edited by charlie; 10-05-2010 at 01:40 PM.

  2. #2
    Join Date
    Feb 2010
    Posts
    28

    Default

    Hi charlie:

    If I use ModuleStreamNameAlias with this StartupStream,
    and aliasmap.stream text file with contents
    Cam1=rtsp://[IP-CAM's IP]/h264/
    Cam2=rtsp://[IP-CAM's IP]/h264/
    Cam3=rtsp://[IP-CAM's IP]/h264/
    Cam4=rtsp://[IP-CAM's IP]/h264/


    How to config StartupStreams.xml ?

    .

  3. #3
    Join Date
    Dec 2007
    Posts
    28,412

    Default

    Try it like this:

    Code:
    <StartupStream>
    	<Application>live/_definst_</Application>
    	<MediaCasterType>rtp</MediaCasterType>
    	<StreamName>cam1</StreamName>
    </StartupStream>
    
    <StartupStream>
    	<Application>live/_definst_</Application>
    	<MediaCasterType>rtp</MediaCasterType>
    	<StreamName>cam2</StreamName>
    </StartupStream>
    Richard

  4. #4

    Default

    Hello Charlie,
    Should there be any issues with using StartupStreams.xml to start streams that are not always present?

    I have rtplive (RTP MPEG-TS) streams that come and go, actually that are not present more than they are.

    I have been having some issues with the smoothness of the rtsp decoding after a week or two and I think it may be related to this. Restarting Wowza fixes the rtsp playback.

    Thanks
    Austin

  5. #5
    Join Date
    Dec 2007
    Posts
    28,412

    Default

    I think it will work, and if they are present at first then drop out, the MediaCaster system will keep trying to restart them.

    Richard

  6. #6

    Default

    Thanks Richard,
    When the streams are streamed to the server they do become available to the iPhone. So they do work as described.

    The issue is, I believe, is when the streams are not present for some time the server tries to restart them over and over. This seems to effect the rtsp requests making them not play properly. The video does not play smoothly.
    Austin

  7. #7
    Join Date
    Dec 2007
    Posts
    28,412

    Default

    Austin,

    You can change the timeout with this Application.xml /MediaCaster property (in milliseconds):

    Code:
    <MediaCaster>
    <Properties>
    <Property>
    <Name>streamTimeout</Name>
    <Value>12000</Value>
    <Type>Integer</Type>
    </Property>
    </Properties>
    </MediaCaster>
    I'm pretty sure that 12000 (12 seconds), as above, is the default. And that this is also the frequency with which it will attempt to reconnect thereafter. And that 0 will turn it off completely.

    Richard

  8. #8

    Default

    I try to Start multiple streams using different ports in mpegts.stream (= multiple streams with the same name).

    So, in my mpegts.stream have udp://0.0.0.0:10000 and I would like to bind another port like 65000.I tried to put in the mpegts.stream both: udp://0.0.0.0:10000 and udp://0.0.0.0:65000 and then I restarted wowza... but java still binf on 10000 and not 65000.

    I also tried to put only udp://0.0.0.0:65000 but, using netsat I still observe that 10000 is binded..

    Am I oblige to use 10000 in my.streams ???

    Thx by advance,

    Regards,

  9. #9

    Default

    You can use any port you like. We just use 1000 as an example. You must have done something else wrong in your testing.

    Charlie

  10. #10

    Default

    So if I want I can specify multiple udp lines in the same .stream right ?

Page 1 of 2 12 LastLast

Similar Threads

  1. Using StartUpStreams.xml
    By kmax1940 in forum General Forum
    Replies: 1
    Last Post: 08-06-2013, 10:05 AM
  2. Replies: 2
    Last Post: 08-09-2012, 10:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •