Wowza Community

An SSL error has occurred and a secure connection to the server cannot be made.

Our StreamLock cert expired yesterday and consequently, our stream went down. At the time, I was receiving ‘Invalid Certificate’ errors. So I requested a new cert from the StreamLock service and reinstalled it on our EC2 instance. The error did not go away.

I then tried changing the password, downloading the cert again, reinstalling it, and still had the same error coming up. The Wowza player actually says something about cross-domain policy errors but inspecting the console the error was ‘Invalid Certificate’ or something to that effect.

I tried the above a few times and finally decided to request a replacement certificate with yet a different password. I have downloaded and reinstalled the certificate and now the error I am receiving is ‘An SSL error has occurred and a secure connection to the server cannot be made.’

Regular HTTP traffic is working just fine, it is only SSL traffic that is failing. However, our users access the StreamLock protected stream just as much as they do the unprotected stream so, it is imperative for us to get this working ASAP.

I would much appreciate it if someone could point us in the right direction. Our stream being down is never a good thing. Please help!

BTW, I did restart the WowzaStreamingEngine service every time I reinstalled the cert. I also changed the configuration files whenever the password had been changed and prior to restarting the service. The permissions on the cert are 775 and it is owned by the wowza user.


Thanks for contacting the Wowza Community!

I suggest you open a ticket HERE and include your config files here /conf and /log files. Only the latest access and error log files are needed.

Can you also include your streamlock hostnames in the ticket and we can check if the renewal went through or not?