Wowza Community

Android > 4.0 Imposible to stream to device. html5 video tag.

Hi guys, I have a wowza server running on amazon. I use this server to stream live and vod stuff to web, iOS devices, and Android devices. For Android devices I’ve been using the html5 video tag with rtsp. Everything worked fine for devices with 2.3 and 2.2 but I just realized that it’s not working for devices with Android 4.0 and up.

I’ve been reading ALL the posts from the forum and I’ve already checked:

  • UDP ports, all opened in my amazon server.

  • I’ve already tried to use http://myServer:1935/vod/definst/myVideoName/playlist.m3u in my html5 tag.

  • “When streaming to an Android device using RTSP/RTP, the RTP portion must flow over UDP. Android does not support RTSP/RTP interleaved (RTP over TCP). This means if UDP is unavailable for RTP playback, RTP over TCP will not work as a failover and your stream will not play.” My UDP ports are opened.

  • If I open http://myServer:1935/vod/definst/myVideoName/playlist.m3u with the video player of my android phone it does stream…

Any idea?


Opening udp ports, etc., is for the benefit of rtsp playback, but you are testing cupertino (HLS) not rtsp.

You might try using HTML5 page with /video tag instead of direct link for the HLS stream.

<video controls src="http://myserver:1935/vod/_definst_/myVideoName/playlist.m3u">

Then open that page instead of the direct link. This might work on recent Android devices, though reports are mixed.

RTSP is still the best way to do simple streaming to Android. Try rtsp directly in a browser on the Android: rtsp://myserver:1935/vod/definst/myVideoName


I’m not able to see my live stream video in the android mobile web working fine in web not an android device @Arun Lokas