Wowza Community

Audio, but no Video

I’m using Wowza Media Server 2 Perpetual 2.2.4 build27452, and I have come across several mp4 files in our collection (encoded from DVD using Handbrake) that only produce sound, no video. I’m using JW Player, as outlined here. I tried re-encoding the films, still using Handbrake as it’s our only encoding software, but the problem persists. The problem also appears when I use the Adobe Flash player, as outlined here. These same mp4 files play fine when streamed from Helix server to QuickTime player, so I know the files aren’t corrupt. Any ideas?

Thanks in advance.

Hello dcaunt,

Can you identify any difference between the working and non-working files using the Gspot or Mediainfo programs?

Otherwise, please post an example of a non-working file. If you don’t want to post a link here in the forums, you can send a download link to and include a reference to this thread.

It seems like a player/encoding issue most likely. If the audio track is mp3, try 44100Hz, 128kbs, stereo. And try to use AAC instead of MP3, if possible.


We stream video from Wowza server. Our player lets user to choose video quality : HD, HQ, SD, all in H264 mp4 encoded with the same software. HD and HQ video plays perfectly but SD (500Kbps encoding) sometimes (may be 1/5 times) play audio without video.

Any clue to help to solve or find a way to solve this problem?

Hi randall,

Thanks for the quick reply. Due to an oversight on my part, it turns out that I wasn’t properly testing the new encoding. Once I realized that, I found that the new encoding of the media did work after all. So, I’m not sure why the old encoding didn’t work, but unless it becomes a recurring problem I’m not going to spend any more time right now trying to figure it out (too many other things to do at the moment). Re-encoding the media is simple enough and solved the problem. But thanks for your suggestions. I’ll keep them in mind if this comes up again.