Wowza Community

Broadcast Suddenly Stopped on Android Platform

Hi Support Team,

We faced a strange issue on 22nd july 2019 in between 11:00 AM to 4:00PM UTC from android platform regarding the live stream broadcasting. The issue was that when an android application is trying to start streaming on a particular channel after complete channel setup then on viewer side there is no stream shown on both platform i-e android and iOS. When we debug the issue on Wowza console then look up Statistics and Video Thumbnail we are seeing only Inbound: Connected is YES with particular channel but there is no stream metadata (Stream Video) was shown on dashboard. We have tried on different networks and different devices like (Samsung S9+,Pixel3a,Pixel 2,Samsung S7Edge) but not fruitful for us.

But suddenly the live stream is working fine on android platform after 4-5 hours. We have nothing changed on configuration or code etc. We have not pushed our build to Production because of this blocker issue.

Can you guys tell us ins and out of the problem that was faced Yesterday.

Also, we are going push our build for 3000 beta users can you please add debugger on our channels so that we will be able to identify the exact issue.

Lets us know if you have any question.


@Rose Power-Wowza Community Manager waiting for your response.

My apologies for the delay @Frederick Ackroyd, I was not in the office yesterday.

Checked with tech support and saw your support ticket and that you were pushing RTSP and also tried the ULL workflow with the same issues. As I have mentioned previously we are still working on full support for the Android SDK and all the devices you have mentioned. But, I will follow up on the my request to the SDK team to make the Pixel support a priority. We appreciate all of your communication with us as it greatly helps us identify how we can improve our product.

@Rose Power-Wowza Community Manager

Thanks for your action that you put forward our pixel series issue on priority basis to SDK team.

Looking forward to the fix.


Update @Frederick Ackroyd:

As a successful workaround, if your Android device is using Android 9, please upgrade your device to Android Version 10 and the broadcast issues will be resolved. Thank you for your patience and we will keep you updated on the next SDK release.

If you continue to experience any significant broadcast issues after you upgrade to 10, please post in the forums so we may look into it.

Thank you.

hi my android phone will not recive android 10 its a nokia 9 there is a way to fix this in android 9 , and the android 8 works with this ?

Hi @Tomas Hurtado, what do you mean it will not receive android 10? Are you trying to playback a stream with the SDK on the Nokia 9? Are you getting any video or audio at all?

I’m just looking for clarity on the situation. Did you upgrade to Operating system 10 and then is what you meant? I will look for your response. Thank you.

hi, the app recently was updated and my problems now are solved thx for the reply

Attentio****n @Tomas Hurtado @Frederick Ackroyd

Issues with Broadcast using the GoCoder Android SDK have been resolved in the new version released today: 1.9.1 build 0636.

Enhancements and fixed issues (since

  • Fixed an issue that was preventing stable broadcasting using GoCoder SDK for Android on certain devices running Android versions 9 or 10.

For anyone who was experiencing broadcast crashes on certain devices using Android OS 9 or 10, please update to this new version to resolve any issues.

Click the link to download and install the latest version: