Wowza Community

Bytes out 0

I’m trying to use wowza streaming engine to transmux a stream that comes from ffmpeg using srt.

In wowza streaming engine I set up the incoming address for an srt stream as “srt://” and have used ffmpeg with the following command:

ffmpeg -re -stream_loop -1 -i stream.mp4 -listen 1 -f mpegts -movflags frag_keyframe+empty_moov “srt://”

I cannot seem to get anything on the output. I’ve tried the test players, playing with ffplay and vlc on multiple urls (including srt://10.0.2.:1935/live/ The stream targets didn’t help either (with ffplay directly or through ffmpeg as an intermediary). Should mention that output bytes remains at a constant 0.

I just want to see if the streaming engine really works and is usable in my project.

I’ve already read and tried everything relevant I could find on the wowza site and further.

Thank you for your help

You send srt on, port 1935 and then let Wowza listen on port 4010 … ? Out of my head, it should work with something like this.

ffmpeg -re -stream_loop -1 -i stream.mp4 -f mpegts srt:// 

And then in Wowza, create a .stream file with source srt:// and start that stream as SRT stream type. Not 100% sure though; you may have to replace with (all assumed that you run ffmpeg and Wowza on the same server)

Thanks Karel for that information!

Keep in mind also @marko barbancic, that even with a trial license (if that’s what you have), you are able to submit a support ticket and our engineers will help you set this up and debug what may not currently be working. If what our Senior Consultant Karel shared doesn’t solve it 100% for you, please send us a ticket so you can accurately gauge Wowza’s capability in this workflow.

Our engineers are more than happy to help get your SRT workflow running. But, tech support does not debug here in the forums- requires a ticket and you can easily submit one here:

Thanks! Just want to make sure you are aware of all the help that is available to you.