Wowza Community

Can't connect to Wowza Engine Manager over HTTPS

I have a problem to connect to Wowza Engine Manager over HTTPS under Debian. Everything seems to be configured properly. The Wowza Engine and Wowza Engine Manager services starts correctly and are active. However each time, when I’m typing the

the following information appears:

Wowza Streaming Engine 4 Developer Edition (Expires: Nov 01, 2017) 4.7.0 build20186

Interestingly after activating the https connection, I’m not able to access the Engine Manager over HTTP. Is this a problem, which is connected with a developer license?

Thank you in advance for your support.


This should not be related to the developer license.

It does look like this is a known issue addressed here:

Please follow the instructions in this article to reconfigure access to manager through SSL:

Hope this helps,


Alex C.

Hi Everyone,

@Pawel Kubzdyl, I experienced kind of the same problem as you when activating SSL on the Admin interface.

I get this message “Wowza Streaming Engine 4 Subscription Edition 4.6.0 build19395” when trying to connect with https but can still access normally over HTTP.

Did you find a solution?

Thanks a lot.


@Wix IT unfortunately this problem still persist. I’m not able to access the Wowza Engine Manager over https. After following the configuration steps defined under:

I’m getting only the following information

Wowza Streaming Engine 4 Developer Edition (Expires: Nov 01, 2017) 4.7.1 build20635

after typing in the browser:

Does any have any idea, what could be the reason?

I havent got this to work either, although i used letsencrypt on the wowza server. As soon as i try the enginemanager part, it totally ruines my server or it will show the same results as the users above here. So im also still seaking for a solution on that to let the enginemanager run on https

Yesterday I got a solution from the Wowza-Team: based on the server log files they found out, that the HTTPS port configuration in the VHost.xml under [wowza-install]/conf/VHost.xml was improperly set to 8090:

We suggest changing this to 443 or another unused port as the Wowza Streaming Engine Manager service will need port 8090 available to bind with.

Additionally it was necessary to reconfigure the file by adding proper paths to jks file.

Now it works with http and https. Finally!

Hi Pawel, thx for the update, will see what i can accomplish on my dev system.

@Pawel have tried it in combination with LetsEncrypt, bu so far no luck on the backend. My ports are ok, but when i change my the enginemanager wont start anymore. Will keep searching on this.

ok, got it work. will post a link to my website for the complete tutorial, i can’t add more then 600 characters in my post.

in short
in VHost.xml port on 443

. i had to change the /usr/local/WowzaStreamingEngine/manager/bin/ file too.

so now i got my wowza server running on a LetsEncrypt SSL on frontend as well as backend.

For users who need some guidance to get LetsEncrypt working with wowza streaming engine (Ubuntu server 16.04 OS)

Note: always test it on your DEV environment first.
@Wowza, if links like this are not allowed, just delete the post, but i can’t add more then 600 characters to explain the complete tutorial.


I’m having the issue outlined in this thread:

  • I’m attempting to use the Wowza Streaming Engine Manager web UI on a custom HTTPS / SSL port (preferred port: 8443).

I’ve followed the various instructions for editing “”, “”, and “VHost.xml” (though I find having “VHost.xml” entry matching my web admin UI SSL port causes the browser to show a media streaming status rather than the web admin UI).

I want to maintain:

  • 80 / 443 for media streaming

  • 8443 for web admin (https/SSL)

Any thoughts, suggestions? I’m currently doing a revert back to “8090” for web admin UI via SSL to see if that works (am awaiting IT to open firewall ports for me)


I should say, I’m not using StreamLock, but a verified CA for generating my certificate and it is available in JKS format


if i see it correct you should change the http port 8088 to https port 8443 (instead of 8090) in the

(just tested it (changing 8090 to 8443), although im running on a letsencrypt ssl, which shouldn’t make a difference)

restart wowza and the enginemanager after the change, and make sure the ports are allowed

service WowzaStreamingEngine restart

service WowzaStreamingEngineManager restart

and opening tcp port 80, 443, 8443 inbound+outbound

if you still want to keep streaming over port 80 or 443 you should add the port in your vhost setup so it kinda looks like this

Give it a try i would say :smiley:

Thank you! I realized that my missing piece was restarting the WowzaStreamingEngineManager. For some reason, I always think restarting WowzaStreamingEngine restarts both the services.

Thank you!!

yw. glad you got it to work.

It is because of many reasons

1.Firewall in your network or in your server block the port you want to use for ssl and https

  1. You might select ports already in use by other services

  2. You might make mistake in editing some files such as vhost.xml,

I also had this issue, finally I can solve it.

  • Detail

After I followed procedures in

I tried to restart Wowza Streaming Engine(WSE) Manager service, but it fail and not running

Be careful for editing file




For [install-dir], You cannot use ${com.wowza.wms.context.VHostConfigHome}. You must use a real path in your OS, fore example

C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.7.7\