Wowza Community

Can't start MPEG4-to-H264 transcoding: videoDecoderDecodeDisplayWidth failed

I’ve got a transcoding problem with a particular brand of MPEG-4 encoders. In particular, I have several Optelecom (i.e. Siqura) C50e MPEG-4 encoders and whenever I try to transcode the incoming video to H.264 I see the following error in the logs:

TranscoderWorkerVideoDecoder.frameDimensionsValid[_defaultVHost_:atmslive/_definst_/ decodeIterations:0]: videoDecoderDecodeDisplayWidth failed [0:32:8192]: Encodes will not be playable

The end result is that the transcoded video never becomes available. I’ve got other other MPEG-4 sources that transcode with no issues using the same Wowza instance. I didn’t find anything similar in the forums or doing a Google search. Is this an issue with the encoder itself? VLC has no problems playing the MPEG-4 video stream from the encoder. Any suggestions?

Windows Server 2016 64-bit
Wowza 4.8.14+9 (trial license)
Nvidia Telsa T4 GPU with CUDA 11.4


Hi @David_Irwin1 this is not your fault, this is a known issue with the trial license and 4.8.14. The video will either flicker, not play or crash the server if multiple attempts are made that burn up all the CPU. They are working to fix it in the next Engine release.

So sorry for the frustration.

An option for you to consider:

Considering the trial is limited to 1 transcode only, swapping out the scaler to the “default” option really won’t be a significant impact.

Thanks for the response.

Can you clarify what you mean by “swapping out the scaler to the default option”? Is this something inside of the transcoder template? Or something else? In the transcoder template I’ve played around with a lot of the settings including the “Frame Size” options but none of those changes have made any difference to date.

I also know that you said that this is a known issue with this version of Wowza. I suppose I should also just wait for the next release; is there a target release date where this should be fixed?


It means turning off the GPU basically. Just don’t select CUDA for the scaler setting :slightly_smiling_face: But yes, that will not use the GPU.

Let me check on the next Engine release date for you.

Thanks for the response…that makes sense.

Unfortunately I’m still seeing the same error in the Wowza log after making the changes. Specifically I went into the “Transcode” template and:

  • Under the ‘Encoding Presets’, select the desired preset and changed the “Encoding implementation” from NVENC to Default
  • Under the ‘Decoding Preset’, changed the ‘Decoder Implementation’ from CUDA to Default
  • Saved the transcoder template changes
  • Stopped any running streams, restarted streams

After connecting the stream, I see this in the transcoded stream details:
The “Bytes In” only changes by 44 bytes every few seconds. In the Wowza logs I still see this:

Let me know if there’s any additional information that is needed.

I’m sorry you are still having issues with it. For an accurate diagnosis based on your configuration and hardware, please submit a ticket for further investigation. You can submit one here: