Wowza Community

Chunklist.m3u8 on version 3.1.2


We upgraded our wowza server to version 3.1.2, and now when using Cupertino streaming it returns a chunklist.m3u8 not playlist.m3u8.

I don’t know if this is suppose to make any difference, but the videos are not playing.

The error given by jwplayer is “The video could not be loaded, either becasue the server or network failed or because the format is not supported.”

We followed the instructions for setting up AES.

This works with another wowza server with an older version.

Do you have any suggestions?


The playlist.m3u8 url will still return the same playlist. And you can get the chunklist.m3u8 directly. What is the playback url you are using? It does now have to use “playlist.m3u8” at the end, whereas anything.m3u8 used to work, but not anymore.

Does it work if you remove AES encryption?


The URL you are using is wrong. Change it to this:


The vod application is setup by default to playback video on demand content.


Test this with the Wowza sample.mp4 file.

If sample.mp4 works, take a look at the contents of your file with this tool:

It might contain Spark or VP6 video.

Otherwise, restart Wowza, run through tests, then zip up conf and logs and send them to

Include a link to this thread for reference.


The error messages look like you are opening from the file system.

And the stream is not live. I tested in Wowza Flash RTMP Player:

Server: rtmp://

Stream: starcricket


What is the source? Your server is up, but that stream is not running. You have to start that live stream.


Hi Richard,

Thanks for your reply.

Uninstalled wowza, and reinstalled it from scratch. used version 3.0.5.

With no AES, the video is still not playing in Ipad, just getting the same error message.

Chunklist.m3u8 content looks like this, no .ts files list:






Url: http://[Internal IP]:1935/vod/mp4:VideoName.m4v/playlist.m3u8

Are there any other configuration needed for Cupertino to work? (Will add AES encryption later)


I am having similar problem, so I won’t be opening a new thread but using this one instead.

I can reach playlist.m3u8 file (wget or get it with player) and then it references chunklist.m3u8 file, but player (or wget) get 404 HTTP error from the server for chunklist.m3u8 file right away, and the playback fails to start.

Configuration is trivial: server configuration is copied from examples/LiveVideoStreaming/conf/live to conf folder, and application/live folder just created.

Stream is referenced as http://localhost:1935/live/mp4:sample.mp4/playlist.m3u8

Example stream is on location as it was installed. It is Wowza Server 3.1.2 for Linux.

Do you know what might cause such a behaviour?



i tried to play and it shows error, like chunklist.m3u8?wowzasessionid=390172372 please fix.i wil give you the screenshot

how can i get fixed.the stream worked before i don’t know why it stopped working