Wowza Community

Closed Captioning formatting

For the life of me, I can not get our closed captions to appear centered and on one line. For some reason, regardless of what I do, they show up right justified and break over 2-3 lines. I’ve seemingly tried everything, without any success. Are there any devs out there that have experienced this issue?

Hi Rich, that sounds annoying. I saw some suggestion in a few support tickets:

1) Please set the “cupertinoVODCaptionsUseWebVTT” to true. We have an article on how to do this.

From the article:

Configure WebVTT for VOD streams in Wowza Streaming Engine Manager

  1. Click the Applications tab, and then click the name of your VOD application (such as vod ) in the contents panel.
  2. Click the Properties tab, and then click Closed Captions in the Quick Links bar.

Note: Access to the Properties tab is limited to administrators with advanced permissions. For more information, see Manage credentials.

  1. In the Closed Captions section, click Edit .
  2. Enable the cupertinoVODCaptionsUseWebVTT property, and then set the property value to true .
  3. Click Save , and then restart the application.

2. From your application, set the following property under Root>Application>TimedText>Properties

You can also set this from the Manager UI by selecting your application, selecting the Properties tab, and in the Closed Captions section, enable cupertinoVODCaptionsUseWebVTT property. You will need to have advanced settings enabled for your Manager login account in order to view the Properties tab.

Save your changes and try your captions again.

3. The formatting kind of depends on the player. Have you tried it in JW Player? Some people have had better luck with the captions display in there vs a native Apple player. You didn’t specify what player you were using though.

Also. you can go to the spec here and when you scroll through. it shows some ideas on positioning the captions in the CSS.

I have found that more devs interact in out public streaming slack channel if you want to ask in there- should you still not get it to work. Definitely try it in JW player first and check the settings for captions in there and in the spec.

1 Like

One additional tip for you to check:

For VOD content you either want your captions embedded in the file or in an external file. Having both of those can and will cause problems with formatting. Please either remove the captions from your MP4 file or remove the WebVTT file.

I am assuming this is VOD but you didn’t say in your post. Good luck!

1 Like

OH MY GOSH!!! YOU ARE AWESOME. I banged my head soft this past week. Systematically eliminating all the variables in the equation b/c our service has many moving parts, the web front-end, encoding service, network storage, db cluster, etc, etc. And I was struck that one of these piece might be impacting us. #LoveSimpleFixes. Thanks so much, this forum is fantastic and has been an invaluable source for solutions our team. I sincerely posted this question as a hail mary attempt, nothing ventured, nothing lost, you made my week!

1 Like

Hey Rich, that was me, I forgot I was logged in under my other account. Your response makes me so happy ,you have no idea! I don’t get a lot of feedback here on whether or not this forum is helpful, so thanks so much and I am THRILLED it’s working.

I appreciate you in here too! Always ask and take a chance, If I don’t know, I will always dig for some hints on a resolution. :grinning: