Wowza Community

"Connection Refused" Error in the Remote Debug on Eclipse


Actually,my purpose remote debug this java project on remote VM application.So, I will take server logs which is relevant my VM and print some logs data to MongoDB.

I think I setted necessary things.But I’m not sure.

I just tried remote debug on Eclipse IDE but I can’t handle it these problems.I read documents.I applied directions but maybe I missed somethings.

These are my logs and warnings.

Also my startup.bat is default now.But also I configured like this and tried.But it doesn’ work:

-Dcom.wowza.wms.ConfigURL="%WMSCONFIG_URL%" -cp %CLASSPATH% 
-Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=1044 
com.wowza.wms.bootstrap.Bootstrap start

It’s my java code:

package com.mycompany.wowza;

import com.wowza.wms.application.*;


import org.bson.Document;

import com.mongodb.MongoClient;
import com.mongodb.MongoCredential;
import com.mongodb.client.MongoCollection;
import com.mongodb.client.MongoDatabase;

 import com.wowza.wms.amf.*;
 import com.wowza.wms.client.*;
 import com.wowza.wms.module.*;
 import com.wowza.wms.request.*;

public class TestWowza extends ModuleBase 

	public void doSomething(IClient client, RequestFunction function, AMFDataList params) {
		sendResult(client, params, "Hello Wowza");

	public void onAppStart(IApplicationInstance appInstance) throws IOException {
		getLogger().info("Test Method OK!!!");

	public void onAppStop(IApplicationInstance appInstance) throws IOException {
		String fullname = appInstance.getApplication().getName() + "/" + appInstance.getName();
		getLogger().info("onAppStop-test: " + fullname);



Firstly,I want to see “Test Method OK!!!” in the logs.It means my java code is running.Than I’ll write my codes which are necessary for MongoDB

In my application,I configured my modules.That’all I have now.

So I want your help about this problem.How can I fix it?

Thanks in advance for your interest…



You might find the JConsole article helpful when trying to connect with Eclipse, which should be similar.

It could be a port issue depending on your Wowza JMX configuration, as it’s commonly on port 8086 or 8084 but you might want to check this configuration in the [wowza-install]/conf/Server.xml file under to be sure.

Best regards,

I did it my project in the other way.

All I want,run my java code at Wowza and see outputs in the server logs.I reliaze that I didn’t configure my Startup Stream which is include my Application(Application also include my java class).

I configured and I can see outputs.

By the way,I did with no Remote Debug.

Thanks your answer,patience and interest