Wowza Community

Connection refused when opening localhost:8088/enginemanager, but engine is running

I’ve done a fresh install of Wowza on the latest MacOS Big Sur but cannot access the admin page on localhost:8088/enginemanager". I get the message:


When opening port 8087 things seems fine after accepting the credentials I provided in the installer:

Port 8087: Wowza Streaming Engine 4 Trial Edition (Expires: Jan 01, 2021) build.. etc.

Disabling the firewall doesn’t make any difference.

Doing the same installation procedure on the Windows partition of my Mac runs perfectly fine, using the same trial lincence key.

I’m already running another instance on an Ubuntu server, agin with the same trial licence key (I need a local instance for troubleshooting purposes).

Hope to find some help here,

best regards, Teis

Sorry to hear you had some issues with that. I’m not sure what version you upgraded from but there were some breaking changes in recent releases (4.7.8) meaning you need to have at least Java 9 running to use version all versions since then including 4.8.5. There were other breaking changes that would affect 4.8.5 as well so please check here.

Once you looked into that, we usually suggest you look at the potential firewalls which it sounds like you did already. We also ask that you do not use the same port for the Engine server that you do for Engine Admin. If you already made sure of that too well then the same rule goes for SSL config. Set that up on its own port too like port 443.

I have seen it where there were other applications running in the background on 8088 and already in use that the customer was not aware of.

We nay need a support ticket to investigate further, but this is usually what we suggest below for people who see that error: connection refused for port 8088:

Can you ensure that you don’t have any firewalls running that may block access to the following Wowza ports (open in both directions)

RTMP/RTMPT/RTMPE/RTSP(interleaved) Streaming TCP 1935

RTP UDP Streaming UDP 6970-9999

JMX/JConsole Monitoring and Administration TCP 8084-8085

If there isn’t any firewall then you can try testing if Wowza is running. Enter the following in your browser


If it returns a version number then that should show that Wowza Streaming Engine is running.


This is the Wowza Streaming Engine Manager process (which you seem to have the issue with). See if it opens when you use the IP address of the server.

1 Like

Remember that Wowza itself and the Engine Manager (admin page) are two separate services. Make sure that both the WowzaStreamingEngine and the WowzaStreamingEngineManager services are running.

1 Like

Ok, issue solved.

When first installing Wowza I unchecked the ‘start up automatically’ field. Later, when starting Wowza manually I wasn’t aware that both the server and the manager needs to be started, as Karel_Boek correctly points out.

Thanks both for your helpful answers.

Best, Teis