Wowza Community

Could not connect to server: http://localhost:8087 - when trying to login to WSE

Hi,

This problem could present from different causes, and it might be best to send us your conf/, logs/ and manager/logs from your Wowza instance so that we can further investigate.

As a quick troubleshooting guide, however:

  • Ensure that Wowza Streaming Engine services are running (there should be two, one for the Engine and another for the Manager)

  • Test the Manager URL from a different browser (http://localhost:8088/enginemanager)

  • If you are trying to access the Manager URL from a different device, try accessing the Manager from the server itself

  • Try disabling any extensions/plugins that you have enabled

  • Make sure that your Java environment variables were mapped out correctly, and that your Java is running correctly

If you are still experiencing issues, do send us the information requested to support@wowza.com from an email address that is listed as a valid support contact.

Michelle

Hi,

For other users, this may also be due to an IP change on the server, resulting in “localhost” incorrectly pointing to the old IP address. You can change this behavior from the Manager page by changing localhost to the server’s IP address. You would need to expand the +Server from the login page in order to view the field for the Wowza Streaming Engine URL.

Alternatively, you can also clear your DNS cache so that localhost is correctly resolving to the new IP address.

Michelle

Hi Glouber,

Thank you. I’m glad you found the information of use.

Michelle

Hi!

I have installed wowza server 4.1.1 in windows 8.1 and it’s successfully installed but at the end of installation i ticked both option but wowza server showing dialogue "Wowza streaming engine didn’t start within thirty second " and when i tried to start from services but not service found like wowza service to start the server and finally start manually from config and bin using batch but in browser its cant connect to and show unable to connect.

Thanks…

Hi Salvadore,

Can you help me in this topic ?

I’ve got the same issue in both WSE 4.1.2 and 4.2.0 Linux 64bit version (standalone server)

I have tried all suggestions above but it doesnt work.

After digging in tcpdump’s captured files and WSE & WSE Manager logs (DEBUG level), i cant find out why doesnt the WZ RESTAPI server respond the web client (or too slowly respond), both of them are binded in localhost!

“netstat -aon | grep 8087” returns many connections established, they’re only closed when the DefaultClientConnection get timed out

DefaultClientConnection Connection 0.0.0.0:40457<->127.0.0.1:8087 closed

Can anyone give me any clue?

Same issue i have been facing, ensured there is no firewall/iptables, ensured 8088 and 8087 are there in netstat -an output. Added ips to whitelist as well. tried reboot multiple times and starting wowza and amanger individually to not avaiil. Looks like Wowza is not mature yet.

nice for sharing…

Hello,

Thank you for the feedback on these issues. Please let me offer some suggestions:

I have the user name and password when setup/install correct, but when trying to login to Wowza Streaming Engine Manager I get this error every time: Could not connect to server: http://localhost:8087.

This may be the result of connecting to a Wowza instance that is running in a hosted/data center environment. Try adding your IP address to the whitelist settings using these instructions from the Quick Start Guide.

Upon startup, WME fails to load. The Manager does load. The following error is seen in the Event Viewer:

Service WowzaStreamingEngineManager400 received unsupported INTERROGATE control, which will not be handled.

Functionally, Wowza Streaming Engine Manager (WSEM) operates in parallel with Wowza Streaming Engine (WSE). It looks like WSE is starting without the WSEM. Try a specific startup sequence to see if that helps the situation. Please refer to these instructions for specifics on how to (1) start Wowza Streaming Engine and then (2) Wowza Streaming Engine Manager.

  1. Using the instructions from the QuickStart Guide, try manually starting Wowza as a service.

  2. Confirm that Wowza Streaming Engine is running by testing this URL, in a web browser, which should return some version information:

http://[wowza-ip-address]:1935

  1. Start Wowza Streaming Engine Manager

  2. Access Wowza Stream Manager using this URL and attempt to login:

http://[wowza-ip-address]:8088

If these issues persist, please create a support ticket by sending an email to support@wowza.com. Please include a reference to this post and attach the following as a .zip (or other archive):

[install-dir]/conf

[install-dir]/logs

[install-dir]/manager/logs

We are very excited with this new release and look forward to hearing from you.

Please keep us posted.

-Tim