Wowza Community

CPU usage of Wowza reaches 100% when receiving SRT stream on Windows

OS: Windows Server 2019
Wowza: WowzaStreamingEngine-4.8.19+4-windows-installer.exe

CPU usage of Wowza process (java.exe) reaches 100% in a few days when receiving SRT stream on Windows.

I believe this is SRT issue#669 and could be fixed by updating srt.dll to version 1.4.2 or later with “ENABLE_STDCXX_SYNC=ON”. (see: Steady Clock)

Actually, this issue could be reproduced quickly by changing the Windows System Clock.

Thank you

Thank you, I’ll be sure we have this in our backlog for technical support.

I’m trying Wowza Streaming Engine 4.8.21+6, but it couldn’t listen any SRT stream from Encoder.
(Encoder works as SRT caller)

  1. open Wowza Streaming Engine Manager 4.8.21+6 with chrome (tcp/8088)
  2. click the Applications tab and select [live > Stream Files]
  3. click [+ Add Stream File] and enter following values then click [+Add]
    • Enter a name for the new Stream File : test
    • Stream URI : srt://
      • specifying an actual IP address (Server or Encoder) or [::] instead of in this step will not change the result.
  4. back to [live > Stream Files] and click [Connect to this stream]
  5. select as followings and click [OK] (displayed Connection successful
    • Application Instance : Connect to default application instance: _definst_
    • MediaCaster Type : srt
  6. move to [live > Incoming Streams] and found is listed
    • but Status of the would not be changed from Waiting for Stream
  7. open command prompt as an administrator and run "netstat -ano -p udp"
    • the command does not show the process opening udp/49152 and of course udpv6

  • (ref.) https:// www
    • [live > Playback Security > Client Restrictions] = No client restrictions
  • in case of Wowza Stream Engine 4.8.19+4 and Wowza Streaming Engine 4.8.20+1, wowza could listen and receive the SRT stream from Encoder in same procedure.
    • the command “netstat -ano -p udp” shows is opened by java.exe process
    • both and actual server interface address worked
  • I encountered another problem on Wowza Stream Engine 4.8.19+4;
    • when I tried “srt://[::]:49152]” for Stream URI : above, Wowza Stream Engine 4.8.19+4 service process would stop working unexpectedly


Thank you for you repro steps. This will be best reviewed by our Support Team. Please send the repro steps, along with the below support info for their review:
[install-dir]/content (stream file that you’re using)