Wowza Community

Creating GCP streaming image fails with api version error

Hi, community.

Recently I signed up free trial and setting up GCP streaming server using this document.

However when I tried making server image, it shows this error message. I have no idea what does api version mean.

gcloud compute --project=<MyProjectName> images create wowza-streaming-engine-480 --source-uri=
ERROR: (gcloud.compute.images.create) could not parse resource []: unknown api version None

As I started with brand new GCP project, I doubt if some GCP setting is missing, but the document doesn’t mention any specific settings, so I believe it’s ok.

I tried this with CloudShell to clear environmental issue on my local PC, but it showed same message. I’d like to ask if someone tried this recently and saw same error or not.

Here is my gcloud CLI version, thank you in advance.

$ gcloud version
Google Cloud SDK 287.0.0
alpha 2019.05.17
app-engine-java 1.9.79
app-engine-php " "
app-engine-python 1.9.89
app-engine-python-extras 1.9.87
beta 2019.05.17
bq 2.0.56
cloud-datastore-emulator 2.1.0
core 2020.03.30
datalab 20190610
gsutil 4.49
kubectl 2020.02.07
pubsub-emulator 2019.09.27

I would suggest you open a support ticket since this involves Google Cloud and then we can look more closely to try and assist you. We have not thoroughly tested all workflows although Engine is indeed compatible.