Wowza Community

Default sign in username and password don't work for Google Cloud

I’m trying to set up the streaming engine on Google Cloud by following this guide ( but I have an issue when it comes to the sign in. I can hit http://[ external-ip ]:8088/enginemanager no problem but I can’t get passed the sign in to the streaming engine manager. The tutorial explains that if you you don’t specify the username and password in the instance’s metadata then the default password is wowza and the default password is your Google Compute Engine instance ID.

Side note: I didn’t specify a startup package so I’m using the default startup package

However, I tried this approach and I every time I was met with the incorrect name or password error message. I even tried adding my own username and password into the instance’s metadata and attempting to sign in with those credentials but this had the same outcome as before.
I searched the Q&A here to see if anyone had come across this problem. It seems some people had come across similar sign in issues when trying to sign into the steaming engine on their local machine. Their issues seemed be resolved by checking their admin.password file in the /usr/local/WowzaStreamingEngine/conf/ directory. So I decided to ssh into my vm instance and look into my conf folder in search of my own admin.password file but it doesn’t exist there. Instead my conf folder consisted of the following files:

  • Admin.guid
  • Application.xml
  • clientaccesspolicy.xml
  • crossdomain.xml
  • MediaCache.xml
  • PushPublishMap.txt
  • PushPublishProfilesCustom.xml
  • Server.guid
  • Server.license
  • Server.xml
  • StartupStreams.xml
  • Tune
  • VHosts.xml
  • VHost.xml

I’ve checked inside all of these files using the cat command searching for possible login credentials but I had no joy. Can anyone advise on where I can find the default login credentials or how I can get around this login issue I’m having with the wowza streaming engine manager? Thanks.