Wowza Community

Disable Access logs

Hi, if I disable the access logs, the wowza will free up memory and CPU usage?

How to disable the access logs?

Hey @Cesar Fernandes, there is only one root logging system that is enabled by default in Engine and you can see how and where to access it here:

The Wowza Streaming Engine is using the Apache log4j logging. In order to disable Wowza logging, you would need to modify the [wowza-install-dir]/conf/ files and disable the logging appenders used to create the Wowza log files.

In the [wowza-install-dir]/conf/ file, I would change the first line from this:

log4j.rootCategory=INFO, stdout, serverAccess, serverError

into this:

log4j.rootCategory=INFO, stdout

You will need to make sure to restart the WowzaStreamingEngine service so that the new settings will be applied.

See if that reduces your CPU usage, but this is not ideal should you or we need to see the cause of an error and of course as I’m sure you know already, would be better to increase your CPU capacity. But, this is what you can do to test it out.

If you look to the left nav once you open that article I linked above, you will see we have an entire documentation section on logging that you may find helpful. In case you need some additional info that I didn’t provide for you.