Wowza Community

empty captions when loading SMIL from S3

I’m having trouble getting webvtt captions to work when streaming HLS from a vods3cf application.

My SMIL file looks like this:

  <head />
      <video src="mp4:video-hd.mp4" system-bitrate="3206200" width="1280" height="544" title="HD" />
      <video src="mp4:video-sd.mp4" system-bitrate="736160" width="640" height="272" title="SD" />
      <textstream src="" system-language="eng">
        <param name="isWowzaCaptionStream" value="true" />

I’ve configured the TimedText section of my conf/vods3cf/Application.xml as follows:

                        <!-- VOD caption providers (separate with commas): vodcaptionprovidermp4_3gpp, vodcaptionproviderttml, vodcaptionproviderwebvtt,  vodcaptionprovidersrt, vodcaptionproviderscc -->
                        <VODTimedTextProviders>vodcaptionprovidermp4_3gpp, vodcaptionproviderttml, vodcaptionproviderwebvtt,  vodcaptionprovidersrt, vodcaptionproviderscc</VODTimedTextProviders>
                        <!-- Properties for TimedText -->

The video plays using HTML5 Video tag on OSX/Safari, and the caption button appears with “English” as an option, but the captions themselves do not appear in the video. The only errors I see in the access and error logs have to do with failure to load srt files associated with the video files, not the srt file called out in the SMIL:

MediaCacheItemBase.init: Item does not exist: amazons3/myassetsbucket/files/8f45781ef8f740e4b1f58fae01e1b30b/

Is it possible to load caption files this way when using HLS over the vods3cf application?

Hello there and welcome to the wowza support forum.

I think the quickest way to troubleshoot this is, if you have not done so already, to open a ticket with support.

Please zip a copy of your /conf and /logs folders and send them to to raise a ticket.



Hello there!

I have exactly the same problem.

HLS+SMIL+Caption work well when in the Wowza content folder, but not if I use S3 as a source.

Did you find any solution for this problem?

Thank you very much!

Best regards,