Wowza Community

Error Occurred When Connecting Stream File

I want to create a Stream File in Virtual Host Stream Files and connect it with LIVE application.

MediaCaster Type was set to SRT.

However, an error of “Unknown action: connect” occurs as shown in the picture below.

Also, I don’t see any stream in Incoming Streams of LIVE Application.

The same error occurs even if the MediaCaster Type is set to other types such as HLS and mpegts as well as SRT.

Please help what the problem is.

For reference, my Wowza version is below.
Wowza Streaming Engine Version: 4.7.7
Wowza Streaming Engine Manager Version: 4.7.7

The SRT related “Unknown action: connect” errors you mention?

This is an issue we’ve seen in some Windows systems when a required Visual C++ redistributable was missing. This is further described here:

Hence, could you please install the C++ redistributable from the link above or from here, and let me know if it helps? (Verify that gets installed correctly by looking under Control Panel>Programs>Programs and Features on your system). Restart your machine(s) for changes to apply.)

Thanks for the reply.

Additionally, the OS environment where Wowza Engine and Manager are installed is Windows 2012 Server.

Can I still install the C++ redistributable package in this case?

I checked the C++ redistributable downloaded from the link, but it is already installed on the server, and I can’t install it when I try to install the file.
Also, the same error occurs.
Is there any other way I can try?

As I said above, my server is windows server 2012 R2.