Wowza Community

Failure to stream with Pixel 3 and Android 10

We’re seeing some strange behavior publishing with Android 10 and Pixel 3 and streaming in HLS where livestreams never get any chunks. The uploaded mp4 (via ModuleS3Upload) looks fine when played directly but can’t be played properly by Mediacache in HLS. Only audio comes through and the chunklist is all .aac’s. The server makes a log “MediaReaderH264Cupertino.indexFile[mediacache/definst/amazons3/]: MP4 video sync table [stss] is empty, will not be able to play video track.” I’m not certain what this means but it seems the mp4 is lacking certain metadata.

This reproduces with go-coder 1.5.0, 1.7.0, and 1.8.0. However, a Pixel 3 with Android 9 works and a Pixel 2 with Android 10 works.

Looking at the mp4s of a working and non working stream with ffbprobe, the working stream has a Data stream that the non-working lacks:

Stream #0:2(eng): Data: none (amf0 / 0x30666D61), 0 kb/s (default) Metadata: creation_time : 2019-09-18T17:21:59.000000Z handler_name : WowzaStreamingEngine

Any ideas what this could be? It seems strange that this particular device/android combination would cause go-coder to fail to emit certain necessary metadata.

Thanks for sharing this @Wiktor Macura …there are other posts on this as well in recent weeks. The update is we are having SDK compatibility issues with those devices and that OS version, but we are actively working on this and are looking to support those devices in the next SDK release.

Appreciate your patience on this since there are so many components to the SDK and we hope to have a new version ready in about a month. I’ll be sure to make an announcement in the forums and tag you. Thanks.

This problem is on Pixel 3 after ugprading to Android 10. Is this something Wowza is aware of or has a target date to fix by?

Thanks for letting us know this @Michael Malinin and I will notify the SDK team right away. What specifically is the issue you are experiencing? Is it also the audio only with no video problem?


The issue is as described by Wiktor in the original post. Just that the issue is happening on Android 10, so upgrading was not a workaround.

It would be greatly appreciated if you could submit a support ticket so we can try and replicate the issues you are having on the Pixel 3 (OS-10) as we are not experiencing anything out of the ordinary.

Having access to your files and logs would be required through a support ticket:

Thanks so much for doing this @Michael Malinin- your feedback is critical to us meeting your streaming needs.

Ok, appreciate that feedback- the same issue. Tech support is asking if this issue is on the Pixel 3a? Can you confirm the exact device? Thanks again @Michael Malinin.

Yes, pixel 3a. Android build number QP1A:191005.007

Thanks for that. Have you tried on any other device with Android 10 OS or no? Our engineers are testing as well to see if this upgrade workaround is not working at all or just not on the Pixel 3a. Thanks and I will keep updating the thread.

It has worked on Pixel 2 with Android 10. We have not reproduced on other devices

I want to clarify that for all those viewing this post, the GoCoder SDK is only for LIVE streams and not for VOD. The original person who posted this mentioned an mp4 upload, yet tagged this post under SDK.

PLEASE respond to this post and clarify if you are having issues with either broadcast or playback on certain Android 9 devices with LIVE streaming only and using the Wowza GoCoder SDK for Android.

My fear is this post is getting mixed with people asking and commenting about different workflows.

Thank you.


Developer Community Manager at Wowza

Hey @Rose Power-Wowza Community Manager,

We are having issues on Pixel 3, Pixel 3XL, and Pixel 4XL devices all failing to broadcast with Android 10. I’ve also opened a support ticket.


Thank you! We are testing for a solution and have been able to replicate it. Not sure if it is a decoding issue on that particular OS, but we are actively testing and researching it. I’ll post an update when I have one @Austin Musice.

Hello Guys, I am having similar issue, related to stopping the stream. It simply hangs the system. Works just fine on android native, but when run from nativescript project, it hangs the system on the endBroadcast, since the state doesn’t get changed. Any ideas about that?

Attention: Issues with Broadcast using the GoCoder Android SDK have been resolved in the new version released today: 1.9.1 build 0636.

Enhancements and fixed issues (since

  • Fixed an issue that was preventing stable broadcasting using GoCoder SDK for Android on certain devices running Android versions 9 or 10.

For anyone who was experiencing broadcast crashes on certain devices using Android OS 9 or 10, please update to this new version to resolve any issues.

Click the link to download and install the latest version: