Wowza Community

Fatal error: 'WowzaGoCoderSDK/WowzaGoCoderSDK.h' file not found

I’m trying to use the framework folder inside

but I get the error:

fatal error: ‘WowzaGoCoderSDK/WowzaGoCoderSDK.h’ file not found
#import <WowzaGoCoderSDK/WowzaGoCoderSDK.h>
1 error generated.

I get that error both trying to use your GoCoder SDK as described in your guides and trying to use a custom pod that includes your framework. I’ve done a lot of attempts.

Thank you for your support.

Hi Francesco,

How are you including the SDK in your project? I usually drag and drop mine into xcode. Is it showing up in your Project > General settings in the Frameworks, Libraries, and Embedded Content section?

Hi Amara,

did you drag and drog the framework folder? I’ve already tried that.

I noted a difference between the tutorial video and the content of the zip file. In the tutorial there is a .framework file with a different icon from other files, while in the zip file the framework is a standard directory. Could it be the cause of the issue? Have you tried to use the last version of GoCoder SDK per iOS?

I will try now and see if I can duplicate the behavior.

I was able to reproduce this. Make sure your framework file path is correct. I added the framework file in Finder to my project directory, and then added the framework through the + button in the Frameworks, Libraries, and Embedded Content section, referencing the file in that project directory and it worked. I think Xcode changed how they build the reference path.

Let me know if this works for you!

Solved :smiley:

Wonderful! Happy coding Francesco!