Wowza Community

ffmpeg generated live stream can't be accessed outside the manage

We are experimenting with using ffmpeg to generate a stream. The output arguments we pass in look something like this.

-c:v libx264 -b:v 5M -pix_fmt yuv420p -b:a:0 1800k -f flv rtmp://

This command will start successfully and you can see it running in the command prompt. It shows up as a stream in the Wowza manager and you can view it with the test player. But when I try to access it in a browser using the dash version of the stream. The browser will either not find the manifest.mpd file at all or I will see the error “No ‘Access-Control-Allow-Origin’ header is present on the requested resource.”

Can someone tell me if there is something missing from my arguments? I’ve tried a few thing like including the flashver info, but so far nothing has worked.

Below is a sample command to deliver a file as live to Wowza Streaming Engine using FFmpeg.

ffmpeg -re -i inputfile.mp4 -pix_fmt yuv420p -vsync 1 -vcodec libx264 -r 25 -g 50 -sc_threshold 0 -threads 0 -b:v: 1024k -bufsize 1216k -maxrate 1280k -preset veryfast -profile:v baseline -tune film -acodec aac -b:a 192k -ac 2 -ar 48000 -af "aresample=async=1:min_hard_comp=0.100000:first_pts=0" -f flv rtmp://

It is important to force the output frame rate, the output keyframe distance (also known as a Group of Pictures or GOP), and enforce the GOP using either “-x264params no-scenecut” or the codec neutral “-sc_threshold 0” option.

If you are having problems playing back that live feed via MPEG-DASH in our test player then try using the demo Bitmovin or other MPEG-DASH player.


**New playback options available with update of Wowza Streaming Engine version 4.7.6

The Wowza nDVR feature enables you to record a live stream with Wowza Streaming Engine while simultaneously allowing users to play or pause the live stream, rewind it to a previously recorded point, or resume viewing at the current live point. Wowza Streaming Engine 4.7.6 adds support to record MPEG-DASH live streams with the nDVR feature.

See our quick start guide here: