Wowza Community

GoCoder SDK + Cloud


  1. I have setup a sandbox trial account + access key + api key.

  2. I have a server that can create a live stream, and returns the information (host address, port, etc) to server.

  3. I have a gocoder trial SDK installed, and I use the following in the iOS app:


gocoder?.config.hostAddress = hostAddress

gocoder?.config.portNumber = hostPort

gocoder?.config.applicationName = applicationName

gocoder?.config.streamName = streamName

gocoder?.config.username = username

gocoder?.config.password = password

all these settings are taken from the response of the sandbox api, and I have verified them by logging into the web interface.

  1. I also follow the other steps in the tutorial to setup and start broadcasting. But I get no response from the Wowza callback function or any update on the status of the state. The state just stays in idle

  2. I then installed the wowza ios test application on my phone and filled the form with the information that the UI was asking, and I get a message: Status is idle, error os “An error occurred when trying to connect to host” (code =15)

  3. I also see in the FAQ that the connection code is needed from the cloud interface, but I see no mentioning of the connection code in the SDK tutorial or the documentation, or in the sample app.

  4. I also tried starting the stream from the web interface and waited a few minutes until it was ready, then tried to stream from both my app and the sample app, and it made no difference.

Thank you

Can’t connect sandbox environment from device.