Wowza Community

How do I turn on Cacti

In the WowzaMediaServerForEC2_UsersGuide.pdf it says “Cacti is included in the Wowza AMIs but is turned off by default.”

Does anyone know how to turn it on?

There are instructions in that guide.


Look on page 23 of this Guide:

Monitoring the Wowza Media Server on EC2 using Cacti



Make sure port tcp port 8080 is open in your Security group, that might be your problem. Then follow these steps:

Getting started with Cacti

  1. Open TCP port 8080 (instructions for opening ports are above in the „Testing your Instance‟ section.

  2. GoTo URL: http://[public-domain-name]:8080/cacti

  3. Login as:

User Name: admin

Password: password

  1. In the left hand column under the „Management‟ section click the link for „Devices‟

  2. On the „Management: Devices” page click the „Localhost‟ device in the „Description‟ column.

  3. Uncheck the „Disable Host‟ setting in the „General Host Options‟ section of the page. Then click the „Save‟ button at the bottom of the page.

Your server is now collecting data and can be viewed on the „Graph‟ tab. Because Cacti only collects data once every 60 seconds it will take a few minutes before your data will appear in the graphs.


Which AMIs have you tried?


It is now here:


You have to add username/password to /conf/admin.password file for access to this.


Cacti works. You probably skipped a step, or didn’t wait long enough or didn’t set the range to short time in the cacti interface (try 30 minutes), or you didn’t enable port 8080 in the Security Group.



Do you have an instance running now that has this problem? If so, please send us a a link to it (ec2 public dns) to Include a link to this post.

I tested that AMI with no zone and zone b, and it did work for me.


That’s great. Can you tell us anything about what made it good?

Thanks for the update,


We tested a theory that this was related to ElasticIP earlier today. And that does seem to be the cause, we were able to replicate this problem by starting an EC2 instance, then associating an ElasticIP, then trying to enable Cacti. The cacti graphs were broken images.

The solution was same as yours: restart Wowza service, after refreshing a few times the broken images were graphs and within a few minutes showed activity data.

We are updating the Wowza EC2 user guide with this information.


Great! Glad it’s working. Thanks for the update and verification.


I’m not sure how to enable cacti or set password in a startup package.

If you are using the Wowza Dynamic Load Balancer you can get an overview of edge usage from the load balancer HTTProvider:


See the package readme for instructions for enabling this HTTProvider.


Might take a little while for data to start showing, or set on wrong scale. Assigning ElasticIP after does break Cacti, at least temporarily.


I answered your other post with same question


Another way to enable cacti is in the startup package:

In startup.xml:


mysql -u root -ppassword < scripts/enable_cacti.sql


update set disabled='' where id='2';

This usually catches is before the elastic IP is set.


I can get it working for sys stats but no wowza infos… seems to be jmx communication buggy!

if i try 2.1.1 ami it’s so easy to get it all working :slight_smile:

but 2.1.2 in no fun!:mad:

i failed on 6 retry from small to large instances…


if i force my instance to start on us-east-1c … bingo!:slight_smile:

instant reporting (few sec) of my streaming…:smiley:

may be a zone problem?!:confused:

AMI ID: ami-26c62d4f

did someone changed the ami?.. or my brain? it looks ok now after starting 5 instances on Zone a c d… cant get zone b to start!

so… i am happy for now!

actually it’s all good!

if i get problems again i will mail you directly my instance public dns…

Thanks for your support!

I go it!

i ran 24 hrs buggy wowza graphing…cati… and got an idea… quite simple…:

service WowzaMediaServer stop and service WowzaMediaServer start!

restarting seems to update communication…

i ad for 24 hrs of this error in cacti… after restart it’s clean!

10/04/2010 10:27:05 AM - CMDPHP: Poller[0] Host[2] DS[22] WARNING: Result from CMD not valid. Partial Result: ERROR:

10/04/2010 10:27:05 AM - CMDPHP: Poller[0] Host[2] DS[21] WARNING: Result from CMD not valid. Partial Result: ERROR:

10/04/2010 10:27:03 AM - CMDPHP: Poller[0] Host[2] DS[20] WARNING: Result from CMD not valid. Partial Result: ERROR:

10/04/2010 10:27:03 AM - CMDPHP: Poller[0] Host[2] DS[19] WARNING: Result from CMD not valid. Partial Result: ERROR:

10/04/2010 10:27:02 AM - CMDPHP: Poller[0] Host[2] DS[13] WARNING: Result from CMD not valid. Partial Result: ERROR:

And does anybody know how can I enable caciti and change its password with startup package ?

Great question i like to Get it too…

also to get the local host enable at startup… would be great… and to get stats from edges automaticly getting adresses from load ballancer…

kind of overview of load ballanced origin edge…