Wowza Community

How to disable airPlay button in Safari on iPhone?


I want to disable airPlay button on iPhone, it seems that to do this I need to add x-webkit-airplay=“deny” attribute to the video tag

I tried adding it on wowza player load with onLoad callback, but it did not help, air play button is still present.

I also tried MutationObserver with no success.

I think there are two possible solutions:

  1. disable native iOS html5 video player (have not found how to do that)
  2. add x-webkit-airplay=“deny” when video element is created

How can I disable it?

Hello @Vsevolod Ss

iOS devices do not use Wowza Player code to playback the stream. Wowza Player hands off the stream to the native iOS player.


Alex Chepurnoy

Wowza Support