Wowza Community

How to install letsencrypt using certbot on Wowza ec2 instance?

We bought the prebuilt Wowza ec2 instance. That thing is strange! What centos version is there? I tried to install letsencrypt on it using certbot because I care about the certificate auto-renewal.

I just couldn’t get it to install, who built that instance? I kept getting error after error, letsencrypt never took me more than 5 min to install on any centos or any linux before.

Is there any guide on how to install it on the aws instance? I couldn’t see any tutorial or article or question on this forum regarding this subject, which is strange since everyone uses cloud hosting nowadays.

This issue is caused by this issue

Once the OS gets upgraded, this issue will be solved.

Thanks Elie for replying to your own post. This also helps me have discussions with our internal teams to get this prioritized. Thank you!

AMIs have been updated.

Sorry to have previously been unclear, per our Engine team the latest AMI is running on the latest version of Linux 1, not Linux 2.

Why not linux 2? it’s too much better and both are free

Sounds like it was a matter of timing and the scope of things involved with this particular release. We are now tracking the work that needs to be done to get us on or compatible with Linux 2.