Wowza Community

How to stream to Facebook using RTMPS ?

Does PushPublishRTMP support RTMPS? What does PushPublishRTMP.setSSL(true) mean?

If not, is there any other way to send a stream to facebook via RTMPS using Wowza java API?

Will be grateful for any help. Thanks

Checking for you @Roman Buta. I know we do support RTMPS with our REST API, but let me check on the java API. Thanks for your patience.

@Rose Power-Wowza Community Manager I want to know how to do it using the REST API please, could you please refer to that article. Thank you.

Sure thing, but I need to first post the solution for the JAVA API for those in the community clicking on this post because is it is tagged for the JAVA API forum:

Here’s the Java API for setSSL boolean

        PushPublishRTMP publisher = new PushPublishRTMP();

You need to make this change to to send it RTMPS @Roman Buta:

It is also possible to enable the RTMP stream target to send RTMPS content to the destination. Open the [install-dir]/conf/[applicationName]/PushPublishMap.txt file in a text editor, find the entry for the RTMP stream target in the map file, and add “sendSSL”:“true”.

You don’t need to do anything else different in the REST API call for RTMP once you do the step listed above.

The “set to true” means you are allowing it to be sent over a secure connection.

If sendSSL is set to true in the PushPublishMap.txt, does it mean that every RTMP target in this application will be sent over SSL? and that specific application will no more send RTMP to non-ssl receivers?

It will added per Map entry and not the full list of PushPublishMap.txt entries.



I use Wowza at Amazon EC2 and I tried to activate stream target to scheduled live streaming on Facebook.

Described solution doesn’t work. PushPublishMap.txt file is located in [install-dir]/conf/PushPublishMap.txt

In Application folder there is only Application.xml file.

I tried to add “sendSSL”:“true” to PushPublishMap.txt file but it doesn’t work.

This is my PushPublishMap.txt file.

Where shall I put “sendSSL”:“true”?

This file has been upgraded for use by the Wowza Streaming Engine REST API. Please avoid hand-editing.

Push Publishing Map file, format:


[src-stream-name]={Profile:[profile], [additional-configuration-items]}

#myStream={profile:“rtmp”, streamName:“myStreamRTMP”, host:“localhost”, application:“live”, userName:“myuser”, password:“mypassword”}
#myStream={profile:“mpegts”, streamName:“myStreamMPEGTS”, host:“”, port:10000, rtpWrap:false}
#myStream={profile:“rtp”, streamName:“myStreamRTP”, host:“”, videoPort:10002, audioPort:10004}
myStream={“entryName”:“Test”, “profile”:“rtmp”, “application”:“rtmp”, “port”:“443”, “destinationName”:“rtmp”, “host”:“”, “streamName”:“690151504736723?s_bl=0&s_sw=0&s_vt=api-s&a=Abw57jXXXXXXXX”}

Please add like above and restart your application.

myStream={“entryName”:“Test”, “profile”:“rtmp”, “application”:“rtmp”, “port”:“443”, “destinationName”:“rtmp”, “host”:“”, “streamName”:“690151504736723?s_bl=0&s_sw=0&s_vt=api-s&a=Abw57jXXXXXXXX”, “sendSSL”:“true”}