Wowza Community

http loadbalancing


does work wowza http redirection (f4m) with flowplayer ?


Hi dubnik,

HTTP redirection for Flowplayer (with the 302 redirect function) should work with Load Balancer. See the flowplayer HDS example and setup for Wowza Streaming Engine.

However, a current bug has been found in the latest build of Load Balancer 4. We are currently fixing this build, and should have a fix in place soon.



HDS streaming with live application works fine, but it does not work with redirect application and load balancer.



I have tried new load balancer, but no success.

Here is what I’have configured

I have setup live edge/origin and dvr edge/origin

Redirection with live application works fine if i use this link it works fine rtmp://load-balancer-ip:1935/redirect/liveedge/live’

Redirection with dvr application doesn’t work with this link http://load-balancer-ip:1935/redirect/dvredge/live?scheme=F4M

but if I use "http://load-balanced-server:1935/dvredge/live/manifest.f4m it works so I guess the application is configured correctly.

I am using flowplayer 3.2.16

I’ll try send it to support.


I have replaced wm-plugin-loadbalancer.jar with the new one and restarted but wowza, but redirect still not working.


[root@wowza-lb ~]# head -2 loadbalancer/version.txt

Load Balancer 4.0 Build 14516

  • Fixed null pointer error in redirection schemes


I have not time for this, but today I have returned and here are my news.

The redircrtion works prefectly with apple hls stream but no luck with adobe hds and flowplayer.

For me it means that servers are congifured correctly, but there is problem with flowplayer.

Do you have any advice what to do with flowplayer, I have licensed flowplayer so it would be great to use this player.


flowplayer returns this error

[ERROR] time 10:41:50.948 :: org.flowplayer.f4m::F4mProvider : 0 null


Any ideas ?


this is my redirect url is load blancer ip

and in browser I get nothing

This XML file does not appear to have any style information associated with it. The document tree is shown below.

and the page is empty.



If you haven’t already done so, please send an email to as instructed by michelle_b above.



Can you should the format of the URL you were using for HDS loadbalanced playback?

Also if you type your full URL for HDS loadbalanced playback into a browser address bar, the redirect should be returned. What is returned for you in this case?



Please state the version you’re using as the latest to date is build 14516.

This information can be found in the LoadBalancer_4.0(.zip)/version.txt file.




This is an issue we have recently discovered and it should already be fixed in the latest Load Balance package available for download in the “How to get Dynamic Load Balancing AddOn” forum article.

Please download the Load Balance package available in the link I mentioned earlier, extract the “wms-plugin-loadbalancer.jar” from the lib/ folder and replace the [wowza-install-dir]/lib/wms-plugin-loadbalancer.jar file with this new one. Restart your Wowza server so that the new .jar file is taken into account and the Load Balancer should work properly.


Hi dubnik,

Hi dubnik,

Please re-download the Load Balancer module and try your HDS redirect again. The fix has been implemented and should now work. If you are still experiencing issues, please send a support request to with the following information:

  1. A zip file of [install-dir]/conf on both the load balanced server and client server

  2. A zip file of [install-dir]/logs on both the load balanced server and client server

  3. Information on which application and stream you used for testing, and the test times

  4. A link to this thread for reference