Wowza Community

HTTPProvider works from Eclipse, not from .JAR

I’m trying to install my first HTTPProvider module for Wowza. Currently, if I run the code from Eclipse, everything works perfectly, but nothing works as soon as I close out of Eclipse - the application just hangs when I go to http://localhost:8086/appcontrol?… .

  1. I’ve added this code to the VHost.xml file:

  1. And the Java code includes this:
package com.wowza.wms.http.appcontrol;
public class HTTPControl extends HTTProvider2Base
{ ... }

(it’s a slightly edited version of this:

  1. Eclipse has compiled the .JAR file to Wowza’s lib/ folder.

I’ve restarted the server several times, to no avail. What am I missing? Also, are there any verbose debug logs for Wowza? The access and error logs don’t tell me anything about what’s going on when the server loads the VHost.xml file and whether it can’t find the class, can’t load it, etc.


Hello there and welcome to the Wowza support forum.

It looks like you are missing the json-simple.jar file in your library. A quick Google search should locate this download. Add that to your /lid folder and see if that makes a difference.

FYI, you can start Wowza in stand-alone mode [install-dir]/bin/startup.bat|

This will display the server activity to the console. It will show any WARN or ERROR messages that may be effecting server functionality. This is a handy troubleshooting tool.

Kind regards,


Hi there. Thanks for the update and glad I could help.

As for your question about logging. My suggestion to run Wowza in stand-alone mode was more of a general tip for future development troubleshooting. Stand-alone mode provides a bit more detail then what you find in the access or error logs.

Kind regards,


Thanks Salvadore! I added the json-simple.jar file, and it works like a charm now.

Concerning the logging, I tried starting up Wowza in the console, but it only gave me the same messages that I found in the logs. So, for example, there was never any message that it was looking for json-simple.jar and couldn’t find it. Are there any logs for that sort of stuff?