Wowza Community

In my case i am getting long response from server

I’m trying to post from camera
using an example

in my case i am getting long response from server
I try to do it several times and after waiting a long time I get that the camera is in the stream

how to speed it up

i core 7
on wowsa 8 GB

may be need change some param?
up/down strem

Thanks for sharing that information. Can you tell me:

  • What browser you’re using and version
  • What version of Streaming Engine
  • Are you seeing anything useful in the logs when it’s trying to connect?

Some additional areas to troubleshoot:

  1. Wowza Streaming Engine 4.8.5 or later is required for the hosted WebRTC publish and playback test pages.

  2. You can use the the Wowza hosted WebRTC test pages with the latest version of Chrome, Firefox, Safari, and Microsoft Edge version 79 and later.

  3. Select UDP as the ice candidate and have that first in priority (see article here)

  4. Make sure you have SSL certificate on port 443 or other port that’s not already in use.

  5. Know that in poor network conditions, the browser may need to adjust the frame rate.

  6. You have the audio codec set to Opus.

If you are still having issues with long connection time, you'll need to submit a support ticket. WebRTC can be require quite a bit of CPU and we can check the logs to see what clues it may be giving.

1 4.85
2 latest
3 — ???
4 yes
5 ???
6 audio DOWD only video
is goog

I want to emphasize that in the samples, you can go in and adjust the frame rate for the camera and audio. Some browsers will “choke” if it’s too high and so you can lower those and see if that speeds things up. It could be a bandwidth issue.

Here is the tutorial showing you where you do that:

I just sent a tutorial video that shows where you can check #3 and #5. I’m not sure what you meant by 6. audio DOWD only video- did you mean “audio down-only video?” I suggest you try it out just like in the video tutorial first with both audio and video enabled with Opus audio codec just to make sure it’s connecting properly, then go back and disable the microphone if you want to test it with no audio.