Wowza Community

[install-dir] for Windows 7 - Help

I am trying to enable https/ ssl. I am stuck with windows 7 [install-dir].


I have configured everything properly. I have turned Firewall off. Streamlock without https with Port 8088 works. Can I get help with Windows 7 install dir. I tried different combinations. Why does Wowza make it difficult. Example my wowza on Windows 7 is located here,

C:\Program Files (x86)\Wowza Media Systems\Wowza Streaming Engine 4.7.5\conf

Please provide me with the correct [install-dir] as I have tried different combinations like,

/Program Files (x86)/Wowza Media Systems/Wowza Streaming Engine 4.7.5/conf/


Thanks in advance…

I can try and help, but as you already know, we require Windows 10 for our most recent Engine version 4.7.7 and Microsoft ended official support for Windows 7.

But, if that’s what you need to use, then just be aware of the security vulnerabilities even if you get the https working. First thing to check os go into where all your Engine folders are that you downloaded and click in the CONF folder. Is your SSL cert in there?

Second is you didn’t need to change ports, you just needed to update your SSL cert name and password.

As far as a path, we don’t force a certain location, we let you choose your own. But the general path would be :

  • Windows – /Program Files (x86)/Wowza Media Systems/Wowza Streaming Engine 4.8.5/

We’d need to take a look to see where you have things after that. We’d also need to look to see if you configured your SSL with port 443 properly. Did you do that step?

Here is a tutorial:

An engineer looked at what you shared and they suspect this either configuration error or an issue with your file system setup in Windows.

We’d need a support ticket to take a closer look and help you. I understand you’re frustrated, but the fastest way to resolve this is to have a wowza engineer look at your folder system and SSL config, especially on older version of Windows and Engine.

Dear Rose thanks so much for your prompt reply. Finally it is working now after following your instructions and redoing every step again one more time.

I am now having a minor issue with 443. I watched your youtube video for the 2nd time . I tested my stream at the JW Player test page as per your suggestion and it is working. So I believe my issue is with Xsplit software. They might not support rtmps streaming…

I would really appreciate if you have any streaming software advice similar like Xsplit that i could use to test my stream on my wowza ssl server.

Thanks so much for everything…


I use OBS. It should run on Win 7, but you’d need to confirm.

Amara, thanks for the info. I will download, test it and will let you know.

Thank you!