Wowza Community

iOS audio not working after call incoming (ex. FaceTime)


We’ve got a problem with the audio while live streaming. When there is a call incoming and we decline the call and back to live streaming. The video works but audio is missing. Although the offical document claim that the streaming will be resumes. But in our case it won’t. Have anyone who has any idea to dealing this?


Hello @Barney Chen, thanks for reaching out. Are you using Streaming Engine or Streaming Cloud with the iOS SDK?

@Rose Power We are using the Streaming Engine. And we use WowzaGoCoder and call startStreaming to do streaming. Also we have registered the WZAudioEncoderSink but when the call incoming. It stop sending back the CMSampleBuffer. I think there is something wrong with recover the audio channel.

Thanks @Barney Chen for that info, let me check with tech support and I will let you know very soon what to do.

I have an update @Barney Chen from tech support for you:

-the CMSampleBuffer will go to 0 and they will need to restart the stream to continue streaming.

Also, the engineers noticed that you are using an older version iOS SDK and it may be worth your time to upgrade: newer builds use the WOWZ prefix instead of the WZ prefix.

We’ve already tried the newest version of SDK, but still not working. Only the audio CMSampleBuffer is nil, video CMSampleBuffer was fine. Is there any way NOT to restart the stream but also can resume the audio? Thanks for previous supports.

@Rose Power The following are the console logs while the call incoming. I’ve been searching the error for a while and didn’t get anything helps.

CTCallState: Incoming

[avas] Unknown selected data source for Port Receiver (type: Receiver)

WowzaGoCoderSDK: Video Capture Interruption Began

WowzaGoCoderSDK: H264 Encoder Interruption Started

CTCallState: Disconnected

[avas] Unknown selected data source for Port Speaker (type: Speaker)

WowzaGoCoderSDK: Video Capture Interruption Ended

WowzaGoCoderSDK: WZH264Encoder - stopBroadcastingInternal

WowzaGoCoderSDK: @@@@@ VideoToolbox compression session created height: 720, width: 720

WowzaGoCoderSDK: H264 Encoder Interruption Ended

Hope these logs can make it more clear. Thanks!

Thanks @Barney Chen for sharing this. I’ll check again with tech support and share this, but they had told me the only solution at this time was to restart the stream. I appreciate you sharing this and I will let you know soon.

I checked again for you. It’s a known issue @Barney Chen and Wowza does not have a solution for you at this time other than to restart the stream. We appreciate your patience.

@Rose Power, have you fixed that ?

i think the problem is in your sdk sir

Hello @Beverly McRyan

We are still working on this issue and the recommended workaround is to stop the broadcast on an incoming call and then restarting the broadcast when returning the app foreground.

We’ll be sure to update the release notes when there’s a build available that addresses this: