Wowza Community

Is it possible to encode and stream from Flash Media Live Encoder to Wowza on MAC min

Hi All,

I got wowza (rtmp) streaming working great incase of udp as I/p and rtmp as O/p.

Just wanted to expose to better streaming environments, i was wondering, is it possible to encode from Firewire using FMLE, and them tell FMLE to stream to wowza on same system (mac mini) or different system (Linux) , and have users connect to wowa to play the stream.

Input - Using Firewire (Satellite IRD -> RCA -> Canopus Capture card -> Firewire-> Mac MINI). (And i can capture this using FMLE).

Required Output - Output from FMLE should go to wowza on same system (mac mini) or different system (Linux ), and output of wowza should be HTTP (i.e users/clients will play the http stream using vlcplayer/mplayer).

Please let me know is this setup possible, if yes what should be the settings on FMLE and wowza (if mac what is the settings, if Linux what is the settings).

Please share your opinion.


Follow the Live RTMP Tutorial:

Select h.264 video format, then click the wrench icon and select Baseline 3 if you are streaming to IPhone or mobile. Also for IPhone, if MP3 audio, select Stereo and rate 44100. AAC audio is preferable, you can get that with a plugin from MainConcept


If the following URL plays fine in Flash:

rtmp://[WOWZA IP]:1935/live/livestream

then to play that same stream on an iOS device the URL is:

http://[WOWZA IP]:1935/live/livestream/playlist.m3u8

For iOS devices you just add a playlist.m3u8 to the Flash URL.


The instructions for using an RTMP based encoder are here:


With live streaming from RTMP push encoder (like FMLE), nothing in the /content folder is involved. If you have an application named “live” with a StreamType “live” and you publish a stream named “myStream”, then you play stream named “myStream” in your player.


URL: rtmp://[wowza-address]:1935/live

Stream Name: myStream

Wowza example player:

Server: rtmp://[wowza-address]:1935/live

Stream: myStream

Some RTP encoder generate a sdp file which you would put in the content folder, then use StreamManager to start the stream.

Look through the tutorials:


Okay, glad you got it working, but I just answered two of your other posts on this subject that you seemed to have solved now in this post, running in circles.


look at this :

Thanks for the reply.

I can give in Flash Media Live Encoder parameters as,

Stream Host :, Stream name: livestream

where is the wowza server IP. Now what do i need to specify on the


file? when i did udp in to wowza, i have specified udp address like [CODE}udp:// where encoder was pushing udp packets and wowza received them.

In this case do i need contents/streamname file?

If no, how can i know where the stream is coming in to wowza?


Thank you Richard for the reply. I was out for some holidays and couldn’t reply on the thread.

Now I can do streaming from FMLE to wowza without modifying any part of wowza (just installed wowza and it worked :slight_smile: ).

I have couple of doubts,

  1. Currently it is streaming on rtmp. i.e rtmp://[wowzaip]:1935/live/myStream is playing fine. Is there any way so that i can get the http instead of rtmp like,

http://[wowzaip]:1935/live/myStream ??? any links to this guide will be great help :slight_smile:

2). Currently i am using live, myStream in encoder (FMLE), what if i want some thing different? say feed01…feed02 etc, only changing in encoder is enough? in addition to this, i want to run these feeds as soon as wowza starts, what other config changes need to be done for StartupStreams.xml ?

the reason is i am going to configure push to another wowza or to cdn or clients would directly connect to this wowza.

[ One more thing. I have used udp incoming from another encoder on diff wowza setup, did changes on content/ file with udp ip, had applications/channel and conf/channel and used StartupStreams.xml to stream the rtmp automatically and this setup is working great]

Any hints on this will be great help. Again thanks for all the support.



Can anybody reply on this?

my streamer is giving this error.

INFO cupertino connect 1315638560 -
INFO stream create livestream.sdp -
WARN server comment livestream.sdp[1]: /Library/WowzaMediaServer/content/livestream.sdp (No such file or directory)
ERROR server comment - MediaReaderH264Cupertino.indexFile:java.lang.NullPointerException
INFO stream destroy livestream.sdp -
INFO cupertino disconnect 1315638560 -

when i played



 rtmp://[WOWZA IP]:1935/live/livestream

Plays fine.

What configuration changes need to done on the wowza side?

Please reply.



Thank you for the reply.

Let me tell you once again. I am pushing rtmp from FMLE to wowza server. The parameters are in FMLE are,

host:- rtmp://[wowza ip]/live
instance:- livestream

Now i have just installed the wowza, haven’t done any changes (changes like , when i was required to stream mpeg-ts i had conf/stream and content/.stream files etc). Looks like since FMLE is pushing to wowza, the moment i played the url in rtmp player it worked. The url is

rtmp://[wowza ip]:1935/live/livestream


http://[wowza ip]:1935/live/livestream/playlist.m3u8

is failed to work.

The error message i get in wowza when i tried playing above http url is

INFO cupertino connect 1175484429 -
INFO stream create livestream -
WARN server comment livestream[2]: java.lang.Exception: QTUtils.parseQTMediaContainer: File is missing 'moov' atom.
ERROR server comment - MediaReaderH264Cupertino.indexFile:java.lang.NullPointerException
INFO stream destroy livestream -
INFO cupertino disconnect 1175484429 

Do i need to do any modification on the wowza side?


Closing the thread as i got rtmp streaming working :slight_smile:

Nothing done on wowza, just installed wowza, created a live folder under /conf/, copied application.xml to /conf/live modified couple of tags as in this tutorial, started wowza server.

Thank you all for the reply.