Wowza Community

Issues with nvidia hardware transcoding

Good morning! I’m attempting to use hardware accelerated transcoding on my Wowza 4.8.18 instance. I have a quadro k4200. If I use software based encode/decode (and scale), everything works fine (except higher cpu load). If I use the nvidia for anything other than encode (i.e. decode or scale), the video is basically a pixelated green screen. I’m using the latest available drivers for the k4200 on ubuntu lts 20.04.

I see in the logs that the nvidia hardware is available and if I run nvidia-smi -q I can see the encoder/decoder load increase.

Any thoughts?


Hi @Tom_Ryan thanks for reaching out. In Streaming Engine 4.8.18, we upgraded to CUDA 11… so have you checked that requirement?

The NVIDIA microarchitecture of your hardware must support CUDA 11, and using NVIDIA driver version 460.00 or later is required. For information about CUDA-enabled hardware, see NVIDIA CUDA GPUs.

Here are some additional docs that may help:

@Rose_Power-Wowza_Com Yes! I made sure to update the nvidia drivers to a version that supports CUDA 11 (CUDA Version 11.4). I do note that I believe my card does not support CUDA scaling (I don’t believe it is a tesla card). I have tried both on openjdk11 as well as openjdk 17. Same results.

Ok thanks, well I think tech support would have to take it from here to investigate in a ticket so they can run tests with your card and 4.8.18. They’ll need full access to your logs and files to diagnose the green screen. Thanks and I’m sure they’ll be able to troubleshoot quickly for you.

Thanks @Rose_Power-Wowza_Com. I’ve submitted it to support.

1 Like

Just to everyone reading this thread and wondering why they are having issues with Wowza since 4.8.14 and Kepler based Nvidia GPUs. Even though Wowza states that “With this upgrade, using Kepler GPUs and CUDA decoding are not supported. For NVIDIA accelerated decoding, use the NVCUVID (also known as NVDEC) implementation instead.” in their release notes, they do not in fact support using NVCUVID with Kepler based GPUs with 4.8.14 (and newer). My kepler card does support CUDA 11 and has the necessary drivers, but does not work with NVCUVID/Wowza. I’ve asked them to update all of their language to reflect the lack of support, but I wanted to put it here so anyone having similar issues will be able to find it. Thanks!

Thanks @Tom_Ryan for this feedback, I’m going to look into that right now with engineering and the docs team. Be back to update this thread soon.

Ok this is what I was told and please feel free to provide feedback @Tom_Ryan

In 4.8.14 Wowza updated to CUDA 11 to match the latest NVIDIA drivers, but this change deprecated “Kepler” architecture. The quickest way to tell these cards is the K at the beginning of their name e.g. k4200.
While this won’t work with the latest version and we do recommend updating their cards (these are like 10 years old). They can downgrade to 4.8.13 and run NVIDIA server driver 440 with CUDA 10.x and it’ll work.

We do have it documented in the 4.8.14 release notes and could probably also include this in NVIDIA hardware specifications, but the deprecation itself came from NVIDIA and not us, so ideally they should be aware their cards aren’t supported anymore.

** I’ll look into making this more visible on all our NVIDIA docs and appreciate the heads up Tom. Let me know if you think anything else should be added. Thanks.

1 Like

Rose, thanks for following up on this. As you note, the card is older (we’ve already ordered a new one), I just was hoping to help others due to the ambiguity in the release notes.

Yes that’s super helpful and I appreciate that! I just sent a request to docs to please include the info we discussed here. Best to you!