Wowza Community

killUnidentifiedSessions: Killing unidentified session: address and cannot connect from OBS on Windows 10

We have a server on AWS EC2. After we added our streamlock cert and port 443 to our Virtual Host setup, we could no longer connect to the server via RTMP. Once I disabled the enable cert and removed port 443 from the virtual host (via the Manager) and restarted, I could then connect again via RTMP.

The error in the logs was as in the question title. We are on WSE 4.8.12+1 (build 20210419174623)
FYI I was not able to tag this post with streamlock or 443.

It was true for other RTMP encoders, not only OBS not only windows.

Is this still a a problem? Did you by chance disable the other HostPort (1935) when you enabled SSL/Streamlock? You can see the complete configuration in /conf/VHost.xml

Yes there is no change. 1935 was enabled, no change to that.

That’s ok, we can see the post, we’re trying to limit the number of tags in the the forums, but I can add StreamLock as a tag today.

Stupid question maybe but did you try to bind your StreamLock to a different port to debug if it was a 443 error or SSL cert issue? I’m also wondering if your StreamLock is still valid.

Other things that you could try is make sure the password is correct and matches what you entered when you downloaded the cert from Wowza. That’s happened to me before and to a lot of customers when it didn’t recognize what I knew was the right password, but when I changed the password, it suddenly worked. It’s weird, but worth a shot and you can change your StreamLock password in your account page.

Other things to check are here and will give you more hints on what may be wrong:

With it being AWS though, that is a variable we may need to take a closer look at through a support ticket, if the above info still doesn’t resolve the issue for you.

Rose, thank you for these suggestions. It turns out that the virtual host configuration cannot be a comma separated list including 443. we had 1935,80,544, and simply added 443 to the end of the list, then enabled the Streamlock cert. Apparently what happens then is that all the ports try to use the streamlock cert and set up SSL.

Oh wow! Glad you caught that and thanks for the info! Good to know…