Wowza Community

Live stream works everywhere except iOS HLS (where only audio works).

Hi, I am using a specific device with specific gsreamer plugin, which enables live camera video stream with hardware accelerated h264 encoding, and I am restreaming that stream using Wowza. (It works the same way as IP camreras, only I am controlling all the software).

Everything works fine using RTMP, RTSP, but when viewing re-stream in iOS, then only audio can be heard, but video is empty/black screen. Debug from iOS developer showed these error lines:

-iPhone-4S-iOS7 mediaserverd[46] <Error>: vxdDec - Frame# 568, DecodeFrame failed with error: 6

, which gives me nothing, because information about this can’t be found online. The HLS by itself seems to be fine, because it can be played using VLC.

The video on the device is encoded with h264, profile: baseline, 640x480, variable bitrate, framrate:30, gopsize: 30. (Tried different resolutions, tried constant bitrate, tried different gopsizes - result is the same).

A strange solution:

Because I knew there is something iOS specific (resolution, keyframe, bitrate) in the h264 that breaks its playback I thought of using Transcoder plugin to re-encode the h264.

And here comes the intereseting part: re-streaming works if I use Transcoder addon without any stream modifications - I use Transrate template with video and audio settings as PASSTHROUGH. So as I understand it shouldn’t change anything in codecs, but why is the end result working in this situation? What’s the magic the Transcoder is doing, so that iOS now works?

Hi there, have you enabled cupertinostreamingpacketizer in the list of the Application.xml file?

What are you seeing in the logs? You can start Wowza in stand-alone mode /bin/startup.bat( on Mac) and view the logs in the console.


No problem at all. Let us know if you need anything else.


I AM REALLY SORRY, but seems like the guy who tested this stream used the wrong link, which in reallity REENCODED the stream, which means that passthrough didn’t happen and now its logical that the stream works.

Anyway I still don’t know why the original doesn’t work.

I will test that tomorow salvadore, thank you.

Hi there I have the same issue in my case I can hear the audio but can’t see the video the screen is just black and nothing please help I am stuck this issue takes 10 days and my progress is zero please help.