Wowza Community

Local setup: WebRTC + firefox - ICE failed, add a STUN server and see about:webrtc for more details

I have locally set up Wowza Streaming Engine with WebRTC as outlined in this doc.

I am using

  • Wowza Streaming Engine 4 Subscription Edition 4.7.0 build20186
  • A self signed cert

I am ingesting a h264 stream from an IP camera and transcoding it to VP8. I have hosted the HTML examples on Wowza Streaming Engine as outlined in the how-to doc. When using chrome, if I go to

And enter the following

SDP URL: wss://
Application Name: webrtcStream 
Name: mystream.stream_vp8

The player connects and begins to stream. This works great.

However, the exact same set up with the same input in Firefox gives the error:

ICE failed, add a STUN server and see about:webrtc for more details

The contents of about:webrtc are foreign to me, so I’m not sure how to effectively debug this. Here is a screenshot of the attempt

Many similar-sounding issues I have found in previous answers mentioned the webrtcIceCandidateIpAddresses and webrtcUDPBindAddress properties that are added to conf/Application.xml - I’ve attempted some trial and error here to no avail. These are the values I’m currently sitting with in my Applcation.xml


Any push in the right direction would be greatly appreciated.

Thank you.


Was anyone able to figure this out?

Thanks in advance!

A bit embarrassed to say but I had placed my configs shown above in the wrong Application.xml - Once I spotted that it worked perfectly. Hopefully another careful look over the set up steps will reveal something you’ve slipped on.

Have you had any success solving this?

I had thought I had resolved this, but it was only working within a dev environment. Once pushed to an external server, I’m seeing it again. Wondering if you have any insight.

anyone able to find solution for this?

2 years later…anyone find a solution yet?

I was able to find something that worked, per WebRTC demo page and Firefox

It only worked for me if UDP is the only ICE candidate. I had to remove TCP completely. Even if UDP is the priority, it didn’t work.