Wowza Community

Low-Latency HLS using CMAF

I’v updated WSE 4.7.8 and configured CMAF.

https://www.wowza.com/docs/deliver-apple-low-latency-hls-live-streams-using-wowza-streaming-engine

I read above article, and setup my application.

cmafSegmentDurationTarget = 500

less than 500, akamai hls web player even can not play.

it delay more than 5 sec.

How to configure Application.xml for reducing latency less than 3 sec?

You do realize that the 500 you have it set as is in milliseconds? We suggest 3000ms (3 seconds) for that setting. Have you tried a value higher than half a second (500ms) as you have it now? You need to make sure the player has enough data to play back and that it is matches the requirements for the following:

What do you have cmafLLChunkDurationTargetVideo set as @ks ko?

Did you see in the docs that it cannot exceed the cmafSegmentDurationTarget?

I even can not play a url, wowza produce a lot of error:

2020-05-19 14:30:20 UTC comment server WARN 200 - HTTPCTESessionService: Rejecting attempt to create session created for streamsegment: [486], stream name: [mystream], application: [cmaf], segmentId: [486], for client: remote Socket: /127.0.0.1:33228 since no content is available for delivery - - - 490.963 - - - - - - - – - - - - - - - - - - - - - - - -

2020-05-19 14:30:20 UTC comment server WARN 200 - HTTPCTESessionService: Rejecting attempt to create session created for streamsegment: [486], stream name: [mystream], application: [cmaf], segmentId: [486], for client: remote Socket: /127.0.0.1:33228 since no content is available for delivery - - - 491.213 - - - - - - - – - - - - - - - - - - - - - - - -

2020-05-19 14:30:20 UTC comment server WARN 200 - HTTPCTESessionService: Rejecting attempt to create session created for streamsegment: [486], stream name: [mystream], application: [cmaf], segmentId: [486], for client: remote Socket: /127.0.0.1:33228 since no content is available for delivery - - - 491.464 - - - - - - - – - - - - - - - - - - - - - - - -

I’m using the default settings of CMAF and enable LL-HLS CMAF already

See my answer in green. If you are confident that your app has the permission for LL-HLS from Apple, send us a support ticket and we’ll take a look. But, your error codes suggest they do not.

NOTE: Test stream playback

LL-HLS streams can be played in native apps on devices running iOS 13. In order to enable low-latency playback, a native app must carry the com.apple.developer.coremedia.hls.low-latency entitlement.

See the Apple Developer Entitlements reference for more information, but note that this pre-release LL-HLS entitlement may not be listed.

@Vinh Nguyen and @ks ko

https://www.wowza.com/docs/deliver-apple-low-latency-hls-live-streams-using-wowza-streaming-engine#test-stream-playback

If you are not aware: Just because Wowza supports LL-HLS doesn’t mean you have a native app that supports LL-HLS. It’s still a new spec and it requires permission from Apple.

You’re right, LL-HLS is only played on iOS devices. Thank you

Hi @Rose Power-Wowza Community Manager,

If I want to deliver CMAF low latency to use in any platform from Android/Web/iOS, What can I do with CMAF configuration to deliver with 3s latency?At this moment, I can deliver stream with 5s-6s latency with cmafSegmentDurationTarget = 1000 and cmafMaxSegmentCount = 3.

Thanks