Wowza Community

Module class not found

I followed the instructions here

and my error log shows “Module class not found or could not be loaded. Check [install-dir]/conf/my-app/Application.xml to be sure all Modules/Module/Class paths are correct: name:ModuleAutoRecordBasicExample class:com.wowza.wms.plugin.livestreamrecord.module.ModuleAutoRecordBasicExample”

I put the file in the correct directory and set permissions/owner/group correctly. What could cause this? I’ve also tried to create my own custom modules and get the same error. Wowza 4. Thanks!


Try restarting the Wowza Streaming Engine, instead of just restarting the application, see if that helps.



Can you please post your Application.xml. It looks like you may have a conflict between versions of the recorder.


Ah thank you! That worked. However, I’m now getting this error:

StreamRecorderParameters: Error creating FileVersionDelegate: com.wowza.wms.livestreamrecord.model.LiveStreamRecordFileVersionDelegate : java.lang.ClassCastException: com.wowza.wms.livestreamrecord.model.LiveStreamRecordFileVersionDelegate cannot be cast to com.wowza.wms.livestreamrecord.manager.IStreamRecorderFileVersionDelegate|at com.wowza.wms.livestreamrecord.manager.StreamRecorderParameters.(|at com.wowza.wms.plugin.livestreamrecord.module.ModuleAutoRecordBasicExample.onAppStart(|at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)|at sun.reflect.NativeMethodAccessorImpl.invoke(|at sun.reflect.DelegatingMethodAccessorImpl.invoke(|

There was a conflict with my Application.xml. Thanks for the help guys!