Wowza Community

Not able to SAVE streams on Google Lamp Stack

I have tried many times by putting in the URL of the Google Cloud Lamp Stack and making the folder WRITE access. I am still not able to write my streams or save incoming streams to the path.

It says “Recorder error” and doesn’t saves the recording. What is it that I am doing wrong?

Hello @Sprintler Technologies. Wowza can’t record directly to a HTTP endpoint, you can only specify mounted volumes as storage space for recording.

In some cases (e.g. Amazon S3), it’s possible to mount the remote storage as a local volume, but it’s not recommended to record directly to these, for performance reasons.

What you can do, is to record to a local volume, then let Wowza automatically copy or upload the file to your remote storage location when the recording has finished. Wowza has written a plug-in that shows how to do this for Amazon S3 (, and I assume it’s possible to change a bit of the source code so that it can upload to the Google Cloud Lamp Stack.

PS: The “Find a Consultant” forums are primarily meant if you’re looking to hire a Wowza Authorized Consultant for a job or a project. Other questions may fit better in the Wowza Streaming Engine forums here: