Wowza Community

One of the cameras not giving any output


We have a NVR with 5 channels for our 5 cameras. 4 of them work just fine but I’m struggling with one last camera.

One of the camera don’t seem to give any output. We have a webpage to watch the cameras via RTSP using flowplayer. That one camera just keeps on “loading” which it never ends. Browser console gives no error on that camera.

Although if I open the camera in the webpage and check Wowza, it’s not giving any output (Bytes Out: 0 @ 0.000 bits/s), but for all other 4 cameras it does when I open the camera on our webpage. Note that the “record” function in Wowza successfully retrieve the video.

The camera even gets a thumbnail on flowplayer but still doesn’t play live feed.

I’ve tried removing the camera and adding back with different stream and camera name. Also tried just renaming, but with no results.

I also updated Wowza software on our server but that didn’t seem to help.

Any ideas what might cause this anomaly?

We have an article on how to connect Wowza Streaming Engine to RTSP cameras. I have linked directly to the troubleshooting section in the article below


I’ve also updated flowplayer but without much help. Here’s the output of a working stream Network tab in Chrome:

And here’s the stream that’s not displaying the livestream:

It just seems so odd that that one exact camera is not working. The other 4 cameras from that location have the exact network and camera settings. Also they’re all the same camera model…