Wowza Community

Problems Creating or Editing Facebook Stream Targets

Anyone else having trouble creating or editing FB stream targets? Everything’s been working fine for us until today.

In the Wowza Admin > Application > Stream Targets, when you click the FB button to “Log In” and select the destination for the stream, it doesn’t provide the usual dropdown to select Timeline, Page, etc… it just returns to the Log In button.

I’ve tried on three diff FB accounts and on 4 diff browsers from 3 diff computers… all same result. It acts like it’s going to log you in, but fails at the last second. No errors on the page or in the logs. Happens whether you’re creating a new stream target or editing an existing one. None of them can log in to a FB account it seems.

Wonder if it’s got something to do with this?

Any advice?

Thanks in advance!

Hi Steve

I’m having the same problem. I’ve removed all of my facebook streaming targets and have tried to re-add them but each time I try to add one I get this message (Log in to Facebook to authorize your account as a Facebook Live stream target.)

I opened a ticket with Wowza support and they seemed to confirm it is a data access issue with the Facebook API and reported it to their engineers. I’m sure they are working on it. I’ll update here when they update our support ticket.

I rcvd an update from Wowza support and they have fixed logging into Facebook stream targets via Wowza Streaming Engine Manager.

I tested and confirmed all is working as expected.

Thanks Wowza!

Ok, so everything worked fine for three days, then we started getting errors… different than the original issue. Now when we try to enable the stream targets, it returns an error. In the logs, it generates two errors: an invalid token error and failed to create the pushpublish live stream error.

We tried editing the stream target, re-login to Facebook and save the stream target… no change. We also tried new stream targets, deleting and recreating existing stream targets, a different Facebook account and disconnect/reconnect the Wowza app from our Facebook account. Still same errors

Anyone else experiencing this? Wonder if it’s related to Facebook’s ongoing API changes?

Oddly enough, we found out of our 12 existing stream targets, 3 or 4 would work with the original destination. But if we changed the destination, it would return an error. No idea why that happened with 3 or 4 stream targets and all the rest returned errors no matter what we tried. Very odd.



Wowza resolved the Stream Target issues we experienced in the 4.7.5 update released yesterday.

Thank you to the Wowza team for the quick response to Facebook’s API changes.

You rock!

Hello @Steve Nichols

Glad to assist.



Hi all,

today we cant stream to Facebook. After clicking to login button a give all permission to Wowza app on facebook the page came back appear as i never clicked on the login button. No error.

We have Wowza Streaming Engine Version4.7.5 (build 21763).

Anyone are experiencing the same problem?

thank you


I’m also getting the same errors in the 4.7.5 build, sometimes it works and sometimes it fails.

I feel like I have to keep turning off the target re-log into facebook a couple times to get it to work.

Yes, we are also still having issues with FB Stream Targets to FB Pages. Some work some of the time, some don’t work at all and some only work on certain FB pages. I imagine FB is still making API changes that aren’t being discussed publicly. We were provided with some additional stream target properties to try, but have not been able to implement and test yet. We had a couple priority projects come up. Maybe we will get to it later this week. Contact Wowza Support if you’re having trouble. They’ve been very helpful and I am sure this will all be resolved soon.


Some users have seen more reliable connections to FB by increasing the new facebook.readWriteTimeout to 15000ms. This property was added in 4.7.5.

Best regards,


Can’t login currently. It happens again.

Cna’t use facebook stream target !