Wowza Community

Record audio only


We currently have a deployment where we receive a RTMP stream which contains both video and audio.

I would like to record the audio part only. Do you know if there is a way of doing this?

Thanks for posting @Ola Dallokken, the important question here is do you need the video at all as part of the live stream or just the audio for both live and the recording? Because if not, I can guide you on how to disable video in the transcoder and record audio only.

I will look for you reply, thanks.

You can create a new Transcoder template for this workflow. Please make sure that you disable video and pass through the audio. You can record that one stream and it will be audio only.

Transcoding Audio Only:

Here is an article on HLS and an audio only stream:

Thanks for your quick replies.

I am able to split out the audio stream and record that as a separate file now.

The video and audio stream is, however, still being recorded, and I am ending up with two .mp4 files.

Is there a way to only record and store the audio file?

Appreciate any help on this.

Are you only trying to record certain streams or certain parts of stream? We need more information to help. You may be recording ALL streams in Engine which is one of many recording settings.

I would suggest there is an error in your configuration and we would need to view your files to correct it. You should not be recording video at all if it was disabled correctly per the instructions above.

We do not debug here in the forums, but we can help you with this. Can you kindly submit a support ticket and we’ll get this set up correctly for you @Ola Dallokken? Thank you.

In this case the intention is to only record the audio part of this stream i.e. the transcoded stream.

The transcoder configuration is working just fine, and it disables video and passes the audio through.

When the box “record all incoming streams” is ticket, it records the incoming rtmp stream with video and audio as one file, and it records the transcoded audio only file as another file.

The question is how to record only the transcoded file, and not the incoming rtmp stream.

I cannot find any settings in StreamRecorder properties or anywhere else where this can be configured