Wowza Community

Recorded MP4 - Audio out of sync in Chrome and Quicktime


We’re having a very odd problem here and I’d really appreciate your help. I’ll get deep into the details, so that you can understand what’s going on.

We have a live 720p MP4 video streaming from Wirecast 6.0.4 via RTMP to a Wowza Server 4.2.0. The video stream is then distributed via AWS Cloud Front to end users via HTTP. All working fine.

While it is streaming, Wirecast records to disk, using the very same specs as the stream. Wowza also records “what it gets” from the encoder. This means that we get a “local copy” on the Encoder (recorded by Wirecast) and a “server copy” on the server (recorded by Wowza).

While we watch it live, everything is perfect. Audio is in sync. All fine. However, when we watch the archived file in Chrome, we notice that the video recorded by Wowza is not in sync with the audio. We download the actual file and play it locally in Chrome, and problem persists. Note that this happens only in Chrome and Quicktime player. If I open the file on VLC or Media Player, audio sync is perfect on the very same file.

Please note that this only occurs on the video recorded by Wowza. The video recorded by Wirecast is perfectly synched.

In other words, it seems that Chrome “does not like” the video recorded by Wowza (although it has no problem playing its live version). Please also note that the audio quality and video quality are fine. The only problem is the audio delayed by around 1/2 second. It appears that the culprit is actually Chrome itself, but I cannot find a workaround for this. Any ideas?

Any help is greatly appreciated.


@HelderConde , Were you able to fix this ?


Wowza places the moov atom at the end of the file rather than the beginning. With progressive download this can be a problem as you need to download the file completely before playback.

Please test the recording with on of Wowza’s sample players. You can find them in the [wowza-install]/examples directory. If you still notice a/v sync please open a ticket with support by following this guide and sending requested information to Please also include a sample recording with a/v sync issue:

How to create a compressed zip file in Windows, OS X, and Linux



Has there been a solution yet? I am facing the same issue with live-record type of application.

@HelderConde , Were you able to fix this ?

Sorry for my delay in answering.

We found a temporary solution, which is not ideal, but seems to be a valid workaround for us until a final solution is found: apparently this sync issue appears whenever Wowza records a main or high profile H.264 video as an MP4 file. What we do now is stream using baseline profile and we also add “flv:” right before the stream name (eg: rtmp://servername/appname/flv:streamname). This forces Wowza to record in FLV format (a H.264 packaged into a FLV container). Then we convert the FLV to MP4 using FFMPEG, without re-enconding:

FFMPEG -i InputFile.flv -vcodec copy -async 1 -acodec copy -y OutputFile.mp4

This simply “changes the packaging”, without re-encoding the contents, so it is a very fast process and no quality is lost. Audio is then correctly in sync.

Hope this helps. And hope Wowza team is able to fix this.



I have posted same issue here and what I have tried . Did not get any update . Have a ticket open with wowza and told that it works for support team with no issue . But I am pretty sure its real issue as many people posting this .

Thanks for the update, Helder. I am happy you found a solution, even if its temporary. And thanks for sharing it here.



Can you please open a new forum thread and provide as much detail about your server specs, Wowza version, streaming process and stream details? This will be much more helpful in troubleshooting your issue.



Sorry to drag an old thread up, but I figured I’d post in an existing thread than make a new one.

I am having the same issue.

Any recorded stream whether I record it as MP4 or FLV, on keyframe and not, all play fine when linked with the players, but when I pull the files and put them in premier to edit them, sound it out of sync. And a simple move of the audio track is not an option. I get one part in sync then seconds later it’s back out of sync.

I used ffmpeg to transcode the files, and tried to move the moov atom to the beginning and end of the file. No matter what it plays fine in VLC and JWplayer, but I need to be able to edit these files in premier.

Has anyone found a solution to do that?

I am on Wowza Engine Version

4.2.0 (build 15089)


In the update 4.4.0 there is a fix that:

“Improved nDVR file converter to reduce audio/video synchronization issues”

I would recommend that you update to the latest release which is one step beyond this previously mentioned release:

Then test again and reply here if this issue still persists.


Jason Hatchett