Wowza Community

REQUEST: remove classes from wms-server.jar

I like to use googles protobuf in one of my modules. However, I struggle with it because during runtime the classes included in wms-server.jar are loaded (instead of the version I included into my fat Jar) which seems to be outdated.

I am currently searching for solutions (shadowing, etc.), however I am wondering why you include these classes into your JAR file at all.

I’m checking with our engineers @Mathias Schneider. I’ll respond shortly.


These classes are currently used internally with one of the DRM implementations so can’t be removed. If it’s important then please open a support ticket so a feature request can be logged to either update the classes or move them to their own jar file so that they can be replaced easily.



Thank you for your investigation and your reply!

I will open a support ticket and I am sure I am not the only one who would appreciate, if you deliver an updated, clean JAR with google protobuf instead of merging the classes into wms-server.jar. See:

Hi there, I’m running into a similar issue today with another Google library. Just want to see if this issue has actually being resolved or any progress on it at all?


Thanks for your messages. Our backend development team is still assessing this request for removing this class from the .jar. At the moment we cannot provide information on whether this would be approved and, if so, when will it be implemented. We kindly suggest you to monitor this article for updates:

Best regards,


@Alberto Cabaleiro, @Roger Littin, is there any news on this? A customer that is building a large-scale OVP on Google Cloud has the same issue, and worst case we’ll have to replace WSE …

Hi Karel,

Still no updates on this, but please keep an eye on the Wowza software updates article posted in my previous comment, as version 4.7.8 is due to be released before end of the year. In the meantime, some customers have found a workaround using “maven-shade-plugin”:

Best regards,


Hi All,

I’m on the product team at Wowza. We have resolved this issue in release, which is currently a Beta release. To get access to the Beta, please contact Wowza support.

It will solved in our next GA release too, which is expected to be Q1 2020.